We have an issue with one computer (Win8) at work where after a cold boot the mapped drives show up but don't connect. This is not normally an issue as the user can enter the drives (despite the red X), but in this instance, the user uses software that accesses the mapped drive and the software/Windows wont allow it, as not being connected. This means that the user will have to restart the computer where the soft boot will connect the drives automatically.

We have all the user mapped drives connected through a bat file.

This would probably indicate the mapped drives trying to connect before the actual network connection being connected. We tried this fix:

Local Computer Policy > Computer Configuration > Administrative Templates > System > Logon > Enable: Always wait for the network at computer startup and logon

It worked for a few days but now the issue has creeped in again.

Any ideas?

  • 1
    If it takes more than an hour to troubleshoot a workstation, re-image it instead. – HopelessN00b Apr 4 '13 at 19:24
  • @HopelessN00b True - Was just wondering if there was a permanent fix for repeating future issues and future Server Fault/Google users! – Guest106106 Apr 5 '13 at 9:53
  • Has anyone come across this issue before and resolved it? – Guest106106 Apr 10 '13 at 17:03

Have seen this before.

Changed the login script to delete the drive and re map it each time

net use /delete p: /y
net use p: \\server\share /persistent:yes

If its still not working, put in a ping or something to delay the script, like a ping.

net use /delete p: /y
net use p: \\server\share /persistent:yes

Doubt its the correct way, but its a fix

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.