Everytime I try to install the Management GUI on Server Core I get this error.

Install-WindowsFeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The source files could not be downloaded.
Use the "source" option to specify the location of the files that are required to restore the feature. For more
information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. Error: 0x800f0906
At line:1 char:1
+ Install-WindowsFeature Server-Gui-Mgmt-Infra -Source C:\mountdir\Windows\WinSxS
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],Exception
    + FullyQualifiedErrorId : DISMAPI_Error__Cbs_Download_Failure,Microsoft.Windows.ServerManager.Commands.AddWindowsFeatureCommand

Under DISM I Get the following

Error: 0x800f081f

The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

DISM Log: https://gist.github.com/michael-manley/5329139

I do know usually this happens when it attempts to download from Windows Update bu as you see with the command I'm attempting to use the WIM File. I tried both the wim:D:\sources\install.wim:2 method, and the mounting and using C:\mountdir\Windows\WinSxS methods, both fail. Server is fully up to date. I have tried a patched WIM as well from a freshly installed Server 2012 Standard fully updated.

11 Answers 11


I tested using this link below. Not sure why but with a fresh server core build (I disabled UAC temporarily FYI) and changed was the last command to only include server-gui-mgmt-infra Seems a bit overkill and complicated to get a feature installed. I've not done extensive testing with server core RTM build. During Beta, I recall being able to use Add-WindowsFeaure -Name Server-GUI-Mgmt-Infra -source c:\sxs but guess not during RTM :( What I couldn't get was using a UNC path for the source, even now.



First, the good part. You can use the DVD as the source.

Install-WindowsFeature -Name User-Interfaces-Infra -IncludeAllSubfeature -Source D:\
Install-WindowsFeature -Name Server-Gui-Mgmt-Infra, Server-Gui-Shell -Source D:\

Next, the bad part. I have successfully used these commands in the past. Today, however, they are not working for me. I've tried using the iso as the source, I've tried using a mounted install.wim, all with no success - I get the same message as the OP.

Some web searching found me How to update local source media to add roles and features. It says that to add features to an existing copy of Windows, the source you are installing from must be at the same patch level as the copy of Windows. Sadly, WSUS is not a solution for this - you have to manually apply all the packages to a mounted image before you can use it to add features.

I guess that Microsoft's answer to this is "just use the -online switch". My reply would be "Yeah, right."


Tried all of the solutions, including a manual mounted ISO with all updates applied. Everything failed. However, I thought about what the process is trying to do and thought about pointing the command to another server running GUI, and it worked. Hope this helps others. Syntax:

Dism /Online /Enable-Feature /FeatureName:ServerCore-Gui-Mgmt /Source:\\[server]\c$\Windows\WinSxS /LimitAccess

Copy the sxs/sources folder from the ISO to a local path on the server (can you say i386 folder) and indicate in your command line where the sources folder is. I tried this from a UNC path and it failed. We stage our servers where they can't access the internet.

  • I tried that, same old issue. In fact one was copied to the local drive. – DrHouse Apr 7 '13 at 5:23

I had the same problem with the Desktop-Experience feature. None of the solutions I found on the Web works.

In a last effort I tried running the setup.exe on the Server 2012 R2 CD to "update" my current Server 2012 R2 installation "to" Server 2012 R2.

This worked and the configuration survived (including domain membership). I just had to set the IP address again.

I don't know what this might break might it looks like it works on my server.


Firstly confirm your edition index in install.wim:

dism /get-wiminfo /wimfile:d:\sources\install.wim

It will produce Win Server 2012 R2 SERVERSTANDARD as index 2, then:

Intall-WindowsFeature Server-Gui-Mgmt-Infra -Source:wim:d:\sources\install.wim:2

The last number is the edition index, change to 4 if running in SERVERDATACENTERCORE.


Really tried all of the solutions listed, in the end this worked for me on my 2012 R2 Core:

Dism /online /enable-feature /featurename:X /All /Source:D:\sources\sxs /LimitAccess

Where X is your desired feature name in Dism format (note: it's not same name as in powershell, you will have to search for it, e.g. my feature name was "telnetserver" vs. powershell "telnet-server")


As discussed here, when you need to get source files for additional features from the Windows installation media, the correct path to look into is \sources\sxs, not \Windows\WinSxS.

So, your command is wrong; if you mounted a Windows ISO image under C:\mountdir, you should use Install-WindowsFeature Server-Gui-Mgmt-Infra -Source C:\mountdir\sources\sxs.


Tried all these too. (What a night!) In the end it was David's brilliant idea to use a neighboring server that led to a solution. I had to add a /All to the command:

Dism /Online /Enable-Feature /FeatureName:Server-Gui-Mgmt /All /Source:\\[server fqdn]\c$\Windows\WinSxS /LimitAccess
  • 1
    This should be a comment under the answer, regarding the extra parameter. – David Makogon Jul 1 '16 at 17:00

Here's how I got my Server 2012 R2 Core system moved over to the GUI. Hopefully it helps someone!

  1. Checked C:\Windows\Logs\CBS\CBS.log after trying to install the feature and saw payload files were missing. Example:

    "Failed to find payload files, component:amd64_microsoft-windows-w..client-ui.resources_31bf3856ad364e35_7.9.9600.18039_en-us_a9315b328356154d, file: wushareduxresources.dll.mui"

  2. From another Server 2012 R2 system that had the GUI and was fully patched, I copied over the C:\Windows\WinSxS folder to a temp folder on my Server 2012 R2 Core server (My folder was C:\TempTest).

    NOTE: I actually had to copy over the WinSxS folder from two different servers because the first time I tried to enable the feature I saw the same payload problems in the CBS.log except it would point to a different version (e.g. amd64_microsoft-...7.9.9600.18066..).

  3. On the server core system: Dism /Online /Enable-Feature /All /FeatureName:Server-Gui-Mgmt /Source:C:\TempTest /LimitAccess

  4. After it installed, it required a reboot.

  5. When it came back up, got the cmd prompt and after about a minute Server Manager popped up (some GUI management features are available after “Server-Gui-Mgmt” feature is installed).

  6. I then used Server Manager to add the “Server Graphical Shell” feature which is under the “User Interfaces and Infrastructure” section and rebooted. You can do this through the command line again with the FeatureName "Server-Gui-Shell"

  7. When it came up, had the full GUI and then installed GUI-related Windows Updates from over the years


I've tried downloading Windows Server 2016 and Windows Server 2019, both .ISO and .VHDX versions, the command Install-WindowsFeature Server-Gui-Mgmt-Infra,Server-Gui-Shell –Restart doesn't work any more.

The file install.wim is there in the D:\ drive

enter image description here

I even tried to mount it on C:\mount but no joy, the command Install-WindowsFeature Server-Gui-Mgmt-Infra, Server-Gui-Shell -Source C:\mount\windows\winsxs won't install the feature.

The only way was to reinstall from scratch and install the right version:

enter image description here

Pretty annoying.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.