0

I am trying to solve a problem, with a Linux server work as host, while qemu guest will have another server intended for subdomain.

I tried to make the host to access the guest server. And I read that this can be done through bridge. But I am concerning that the bridge only works with the wired interface, because I wish to make the guest server accessed by any connection to the host server.

To simplify, I wish to setup my host server which contains the guest server as a subdomain, and the server can be accessed by other computers.

I have tried to use qemu with "redir" options, but it doesn't work with "-net user". I tried with redirection because I think I can use Apache to create the subdomain with different port.

Is there any solution?

(Besides that, I have a very poor knowledge about the networking especially bridge, tap, tun, and vlan.)

closed as off-topic by Magellan, Ward, MadHatter, mdpc, Nathan C Jun 30 '14 at 18:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – Magellan, Ward, MadHatter, mdpc, Nathan C
If this question can be reworded to fit the rules in the help center, please edit the question.

0

The problem is solved by bridging or using TAP for the virtual machine part.

Using TAP,

  1. create the tap0.
  2. bring up the tap0.
  3. assign the IP to tap0.
  4. setup the iptables and start the iptables service
  5. run qemu with tap option.
  6. assign an IP in guest so that route to the tap0 IP.

Another method is using the bridge,

  1. create the bridge, br0
  2. bring up the br0
  3. assign the IP to br0
  4. run qemu with bridge option. It will create tap by itself
  5. assign an IP in guest so that route to the bridge IP.

These steps not yet allows the remote computer to access the guest server.

Not the answer you're looking for? Browse other questions tagged or ask your own question.