We have some PowerEdge CS24 servers that won't run Windows Server 2008. Both installer and cloned images promptly BSOD on boot with an error The BIOS in this system is not fully ACPI compliant. I noticed the ones that did work had a newer bios version. So I've set about looking for bios firmware updates for these servers.

enter image description here

First looked at the motherboard for a specific model number, but I did not find one. A search on Google resulted in a Dell manual for PowerEdge C1100 that says Regulatory Model: CS24-TY. The provided bios updates for that system (Red Hat version) failed, but at least returned a potentially useful error message:

Your system: CS24-VSS

Further searching on Dell's site or Google for "Poweredge CS24-VSS" yielded no useful results. Nor was I even able to find the two firmware version we already have: S29S3A03 or S29S3A10.

The AMIBIOS displays version info, but doesn't show anything else about the motherboard:


I used the service tag on Dell's support to reach an article that said:

Currently, there is no online documentation for your selected product.

Where should I go to find bios firmware updates for PowerEdge CS24-VSS?

I installed CentOS 5 on one of the machines to run the Dell Server Update Utility version 5.5, however it failed to detect any known devices, and the server log includes messages such as this is not a Dell Machine.

any known devices

[root@centos ~]# getSystemId
Libsmbios version:      2.2.27
Product Name:           CS24-VSS
Vendor:                 Dell
BIOS Version:           S29S3A03
System ID:              Traceback (most recent call last):
  File "/usr/sbin/getSystemId", line 124, in ?
    sys.exit( main() )
  File "/usr/sbin/getSystemId", line 106, in main
    sys.stdout.write( "%s\n" % info[1]() )
  File "/usr/sbin/getSystemId", line 52, in get_system_id
    return "0x%04X" % sysinfo.get_dell_system_id()
  File "<libsmbios_c._peak_util_decorators.rewrap wrapping libsmbios_c._common._errorOnZeroFN at 0x09680614>", line 3, in _errorOnZeroFN
  File "/usr/lib/python2.4/site-packages/libsmbios_c/trace_decorator.py", line 108, in trace
    result = func(*args, **kw)
  File "/usr/lib/python2.4/site-packages/libsmbios_c/_common.py", line 57, in _errorOnZeroFN
    _doExc(exception_fn, result, func, args, _("function returned error value of zero") )
  File "/usr/lib/python2.4/site-packages/libsmbios_c/_common.py", line 26, in _doExc
    raise exception_fn(r, f, a)
Exception: Could not determine System ID.

Seems like a dead end at this point.

  • Do you know the service tags to these servers? – colealtdelete Apr 9 '13 at 14:31
  • Actually yes, some of them have service tags on front panel stickers. – isuldor Apr 11 '13 at 5:23
  • 1
    You wont have much luck finding any info on this product. Your best bet may be using a similar BIOS, what revision are the "newer" models running? – David Houde Apr 11 '13 at 6:34
  • The newer version is S29S3A10 – isuldor Apr 11 '13 at 7:13
  • Looks a little bit like the PowerEdge SC1425. Can you provide a photo of that server? – Nils Apr 11 '13 at 14:45

I don't have a good answer for you directly, but these folks http://www.theserverstore.com/content/dell-poweredge-c1100-1u-server-2x-xeon-l5520-226ghz-cpus-36gb-memory-4x-hdd-trays are selling c1100s and claim to have updated the machines to the latest version, so they might be a place to get the update.

Apparently these machines were kind of weird custom things which is why it's so hard to find information on them (cf. http://en.community.dell.com/support-forums/servers/f/956/p/19492940/20305446.aspx#20305446).

| improve this answer | |
  • Thanks, but it seems like a long shot since I already ruled out C1100 bios updates which are available from Dell. I went ahead and sent him an email anyway, for the sake of being thorough. – isuldor Apr 13 '13 at 6:37
  • 1
    I agree it's a long shot but I think it may be all you have. Please keep us in the loop about your findings as given the price and quantity out there I suspect you are not the only person dealing with this. – MikeBaz - MSFT Apr 14 '13 at 13:51

This looks like a pretty old server. I would give it at try with the Dell-Update-DVD Version 5.5.0

| improve this answer | |
  • I also just tried the latest SUU release, 7.2. Same result. Bummer. – isuldor Apr 17 '13 at 13:01
  • @briankb not a dell machine? Did you try to install OMSA 5.5.0? For that you hav to add Tikanga to /etc/redhat-release on your CentOS 5. – Nils Apr 17 '13 at 13:26
  • OMSA resulted in the same error Inventory collection stopped as this is not a Dell Machine. – isuldor Jul 20 '13 at 18:48
  • I also tried out Dell's hardware repo, but it wasn't able to find any compatible firmware packages. – isuldor Jul 20 '13 at 18:57
  • @briankb Have you tried calling the Dell-server-hotline? I found that they do help with information even if there is no maintenance any more. But they will not send you replacement-parts for free, of course. – Nils Jul 20 '13 at 21:22

The Workaround

So in this scenario, we have a set of identical machines running either of two different versions of bios firmware. The older version has a defect, so one workaround is to simply use the newer bios version as a replacement. That means we need a utility to dump the firmware contents on one machine, and then flash it onto the others. I'm sure there's several applicable tools, but I ended up stumbling onto one provided by Intel.

Intel includes a DOS based firmware flashing tool called AFUDOS.EXE with some of their firmware packages. I didn't find a definitive place to obtain this tool, so I just used the one included with this driver. AFUDOS didn't need any dependencies, so I just thew it on a bootable FreeDOS usb drive I made with Rufus. Then it's simply a matter of booting the machines and running the tool. The tool has a built in check that will cancel any firmware flashing if the binary is the wrong size. Still, be advised that you may run the risk of damaging your equipment if you use this tool improperly.

After booting to FreeDOS, I dumped a copy of the newer firmware from a CS24-VSS machine:

C:\> afudos.exe S29S3A10.bin /O

Then I used my USB to flash another CS24-VSS machine:

C:\> afudos.exe S29S3A10.bin /P

This is certainly an extreme solution that probably won't be applicable to many other situations. Unfortunately it seems David Houde's intuition was correct in this case. Dell doesn't provide any firmware updates for these particular machines. I'm glad that I found any solution at all. I just finished building a new Microsoft Deployment Toolkit server and these machines were not able to run WinPE for the same reason. But with this workaround, it's all working now!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.