I have a SupoerMicro board with ipmi, where I have some problems in communication using the LAN channel.

The server is running PFsense (netbsd) and I can sendt commands to the local ipmi controller by using IPMI tool. In the beginning I was able to set parameters, but at one point it hangs, and in some way got out of sync.

lan print 1
Set in Progress         : Set Complete
Auth Type Support       : NONE MD2 MD5 PASSWORD
Auth Type Enable        : Callback : MD2 MD5 PASSWORD
                        : User     : MD2 MD5 PASSWORD
                        : Operator : MD2 MD5 PASSWORD
                        : Admin    : MD2 MD5 PASSWORD
                        : OEM      : MD2 MD5 PASSWORD
IP Address Source       : Static
IP Address              :
Subnet Mask             :
MAC Address             : 00:00:00:00:00:00
SNMP Community String   : public
IP Header               : TTL=0x00 Flags=0x00 Precedence=0x00 TOS=0x00
BMC ARP Control         : ARP Responses Enabled, Gratuitous ARP Disabled
Default Gateway IP      :
Default Gateway MAC     : 00:08:74:ef:76:81
Backup Gateway IP       :
Backup Gateway MAC      : 00:00:00:00:00:00
802.1q VLAN ID          : 40
802.1q VLAN Priority    : 0
RMCP+ Cipher Suites     : 0,1,2,3,6,7,8,11,12
Cipher Suite Priv Max   : aaaaXXaaaXXaaXX
                        :     X=Cipher Suite Unused
                        :     c=CALLBACK
                        :     u=USER
                        :     o=OPERATOR
                        :     a=ADMIN
                        :     O=OEM

I can with out problems set the SNMP Community string or the VLAN ID, but I can't set the vlan to off or setting IP Adress, Subnet Mask.

When trying I get this error:

LAN Parameter Data does not match!  Write may have failed.

I have tried a bmc cold reboot / warm reboot and tried so setting the lan mode using raw parameters

to get lan mode 
ipmicfg -raw 0x30 0x70 0x0c 0 
to set lan mode dedicated 
ipmicfg -raw 0x30 0x70 0x0c 1 1 0 
to set lan mode onboard/shared 
ipmicfg -raw 0x30 0x70 0x0c 1 1 1 
to set lan mode failover 
ipmicfg -raw 0x30 0x70 0x0c 1 1 2 

But nothing helps.

It could be related to this question, Supermicro IPMI no network, but he got no solution.


The error LAN Parameter Data does not match! Write may have failed. happens due to prohibited write/change of IPMI/BMC parameters.

The prohibition applied when in Section [LANCHANNELS] the parameter LANFailOver equals enable. To be able to change network settings of IPMI, this parameter should be set to disable to the time of change. Here is how to do that correctly:

syscfg /lfo disable
ipmitool lan set 1 access off
ipmitool lan set 1 ipsrc dhcp
ipmitool lan set 1 access on
syscfg /lfo enable

This example changes the IP source to DHCP. Other settings can be added too.

Interesting: the reason Firmware upgrade helped Lauer to solve the issue seems in LanFailover disabled by default in that particular version of the firmware.

syscfg is a free tool to be downloaded and used.


So, the problem was an old firmware on the supermicro board. After upgrading the hardware, the problem disappeared.


I got this when trying to disable the default gateway by running

ipmitool lan set 1 defgw ipaddr

This worked on other machines, but on that particular one I got the "LAN Parameter Data does not match! Write may have failed." error. The machine had an old X9SCL board with an old BMC firmware version 1.86.

As a workaround I set the default gateway to the machine's own IP address instead.

Once the firmware was updated to 3.52 the above command worked. (This update also fixed a "Command not supported in present state" error when trying to change a user's name.)

Edit: on a X11SPI-TF a default gateway of failed even with the latest BMC firmware version (1.69). Using the machine's own IP worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.