2

We have a Powerbay NAS device and there are 3 iMacs connected to it, when we initially created folders/files on the NAS device the iMacs had an incorrect Mask setting. So the folders and files were created with the incorrect permissions.

The problem is now that nobody can move/change/delete files.

I've tried logging into the NAS device as the Admin and changing the permissions on my userid to have read/write/delete permissions, then via the command line, I've tried:

chmod -R 777 directory_name 

but I still get permission denied.

Any help appreciated, this is causing a bot of hassle at the moment.

Regards, Stephen

  • How is it connected to the iMacs? Samba? iSCSI? NFS? FTP? – Grant Apr 18 '13 at 16:25
  • @Grant its Samba. – Stephen Apr 18 '13 at 16:30
  • If the Admin user cannot change permissions, then it means the Admin user is not the root user. Assuming that this powerbay is essentially linux with CIFS export, that means you have two things to deal with. (1) local permissions.. the ones you tried to change. and (2) ACL permissions, set by the CIFS configuration. look at the directory with an "ls -ld" and post the answer here, so we can give you a bit more advice. It would also be useful to see the output of "ps waux | grep -i smb" or "ps waux | grep -i samba" – T. B. Jan 5 '17 at 20:18
0

It seems more like an issue with the SMB permissions, rather than just the filesystem.

I never touched a Powerbay NAS, but probably is not so different from others. I would

  1. check user's permissions on admin
  2. check SMB config in both NAS and
  3. check your authentication in the NAS ¿Is it done properly?

Hope it helps ;)

0

Check your Samba configuration: Samba does enforce its own permissions, additional to the permissions set on the filesystem.

How your particular NAS device lets you configure Samba should be documented in the manual(s) provided by the manufacturer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.