When I run the command: svnadmin lslocks My_Repo| grep -B2 user_name, I get about 10 files which are locked. Other people see that this user has them locked in TortoiseSVN. When I run svnadmin rmlocks My_Repo on these locked files I get a message that "it isn't locked".

  • This is happening with one specific user who claims they have had strange locks showing up in their name ever since they had a crash while in a working copy on their desktop. I am not sure what the server is confused about though, why does lslocks show locks and rmlocks see no locks? – user160910 Apr 18 '13 at 15:00
  • what does the user actually see? – sendmoreinfo Apr 28 '13 at 12:29
  • The user sees "file is already locked by <username>", exactly what you would see if the file or directory is actually locked. – user160910 Apr 28 '13 at 19:39

Wow, this one wasn't hard after all. If the Path has spaces in it, svnadmin rmlocks will consider that to be a different argument delimited by a white space! I got around this issue by using: svnadmin lslocks Software |grep Path|sed -e 's/\(^Path: \)\(\/.*\)/\2/' -e 's/ /\\&/'|while read my_path;do svnadmin rmlocks Software "$my_path";done

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy