We have a Windows 2012 (VMware tools version 9.0 build 782409) server running on a ESXi 5.1 build 786111 host that has been losing connectivity recently and so far only a reboot has restored it. So far this has only happened twice (4/10/13 ~3am, and 4/18/13 at 2:40am) and thus far we have been unable to identify any kind of cause or reason for this loss. ESX shows no log information relating to any drop in connectivity and none of the other guest have lost connectivity. The only information we have is a single repeated entry in the event log around the time it starts. The host is a DL380p Gen8 running 4 guests, and we have not been able to reproduce the issue in a Hyper-V (2008r2) test environment, nor can we reproduce it on demand. The server is our Sole DC and also hosts file/user shares.

Event log entry:

The event provider encountered a non-fatal error. Some information may not be available.

WBEM Indication Properties 
AlertingElementFormat: 0 0 (Unknown)
AlertType: 2 0x2 (Communications Alert)
Description: "The event provider encountered a non-fatal error. Some information may not be available."
EventCategory: 45 0x2d (Software Application)
EventID: "14"
ImpactedDomain: 4 0x4 (System)
IndicationIdentifier: "{DE5C8142-3FE9-42EA-AD6A-8CBDBE823C94}"
IndicationTime: "20130418020240.559000-240"
NetworkAddresses[0]: ""
OSVersion: "6.2.9200"
PerceivedSeverity: 3 0x3 (Degraded/Warning)
ProbableCause: 1 0x1 (Other)
ProbableCauseDescription: "Provider Cannot Access Data Source"
ProviderName: "HP Ethernet"
ProviderVersion: ""
RecommendedActions[0]: "Isolated instances of this event are not a cause for concern. If continued instances of this event occur, contact HP Support."
Summary: "Provider cannot access data source"
SystemCreationClassName: "HP_WinComputerSystem"
SystemFirmwareVersion[0]: "2012.06.22"
SystemGUID: "EB824D56-4B37-835A-96B9-E9D1718A77A6"
SystemModel: "VMware Virtual Platform"
SystemName: "Server.example.local"
SystemProductID: ""
SystemSerialNumber: "VMware-56 4d 82 eb 37 4b 5a 83-96 b9 e9 d1 71 8a 77 a6"
TIME_CREATED: 130107385943390813 0x1ce3bfa69cf7a5d
VariableNames[0]: "FloodControl"
VariableTypes[0]: 1 0x1 (string)
VariableValues[0]: "HP Ethernet detected too many changes happening to the network."

What we have tried so far:

  • Disabled/re-enabled the NIC inside of Windows
  • Changed which physical NIC the guest uses inside the vSwitch
  • Changed cables and switch ports used

Any suggestions on possible causes or solutions would be greatly appreciated.

I noticed a similar question here but it was a little to vague and wasn't sure if this would be a duplicate as the ESX/OS versions were different.

  • Was this VM converted from a physical server? If so, did you remove any vendor specific drivers, management programs, tools, etc. that would be relevant for the physical server but not for the VM? For instance, if the physical server had a management utility or driver package for the NIC this wouldn't be needed in the VM since it uses virtualized hardware. – joeqwerty Apr 18 '13 at 16:18
  • This server was a new install to replace an aging 2k3 server. We have the junior administrators install HP's SPP on all the physical servers for monthly preventative maintenance if there is a new version out, which looking at the new god-awful start screen shows HP System management and the HP Array configuration utility are installed. I will uninstall them along with wbem, insight agents, and whatever else got installed with them. – David V Apr 18 '13 at 16:38
  • So did the HP tools get installed in the VM? The event log entries are from the VM right? – joeqwerty Apr 18 '13 at 17:02
  • It appears so. The event log entries are from the VM yes. – David V Apr 18 '13 at 17:22
  • Then that is likely the problem. The VM doesn't need any vendor tools installed as it doesn't have any vendor hardware. Vendor tools get installed on the host. Only VMware tools get installed on the VM. – joeqwerty Apr 18 '13 at 17:25

The VM doesn't need any vendor tools installed as it doesn't have any vendor hardware. Vendor tools get installed on the host. Only VMware tools get installed on the VM.

  • Unless proven otherwise this is the most sensible solution so I don't think it'll be fair to wait and see if it happens again. – David V Apr 18 '13 at 18:48

I've had a similiar issue with Windows Server 2012 with permanent loss of connection of second adaptor about once a day. Disable/Enabled solved for some hours.

You've upgraded from 2k3. Have you changed Guest OS Setting?

(VM->Preferences->Options-> Guest OS)

If not your virtual network card is probably "E1000" or someting else, with Guest-OS set to "Server 2012" you will get E1000E adaptor

  • I've removed old adapters in Windows in device-manager (otherwise you may get problems stating address is in use on other adapter)
  • shutted down
  • removed virtual NICs
  • changed to Guest OS to MS Win Server 2012
  • added E1000E Adaptors
  • booted and assigned IP Adresses to new adaptors

I've figured this out because other Server 2012 on same VM Host didn't had that problem and this was the only difference (because we installed new Windows on the old VM).

  • Our specific issue was due to the HP tools being installed, but we will be converting a bunch of 2008/r2 machines in the not too distant future so these will be nice to add to the checklist. – David V Nov 7 '13 at 6:52

Uninstall the HP management agents. They do not belong inside of a virtual machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.