This is what it's all about: I've got a Linux network with an actual hardware server running two separate virtual machines and a QNAP NAS T-459 Pro+ as a fileserver. Since updating the QNAP firmware on the NAS, the main server cannot access the ISCSI drives anymore.

Effect: All net drives at the workstations are not accessible anymore, so you can't access any file from there.

The hardware server is running XenServer as a virtualisation software, providing one VM as a VPN gateway and another VM as a Samba server (

Whenever I try mounting the ISCSI drives on the Samba server using the UUID (as in /etc/fstab), I get:

server01:/home# mount 2d3e150d-a259-4a82-bfe5-f60c6785bc06 /mnt/nfs/backup -t ext3 mount: special device 2d3e150d-a259-4a82-bfe5-f60c6785bc06 does not exist

Though it is possible to access the QNAP-NAS ( from the Samba server via ssh. I've mounted a NAS-folder on the Samba server using NFS.

Attached I will send you the last entries in /etc/logs/kmsg.

Have you got any ideas? I'm quite desperate, the only thing I could think of is switching the whole ISCSI connections to NFS, though I don't know if that brings any other trouble. What do you think? And could you help me switching it (or solving the problem in another way), as my knowledge end when it comes to NFS and ISCSI? That'd be great!

2 Answers 2


Try to check if uuid hasn't changed:

ls -l /dev/disk/by-uuid


blkid /dev/sda1

Maybe fstab entries are outdated by some way?

  • Hi Marek, thanks for your answer! ls -l /dev/disk/by-uuid returns lrwxrwxrwx 1 root root 10 19. Apr 13:15 7a640380-d986-430d-aaa3-b4fcc89f9035 -> ../../hdb1 While blkid /dev/sda1 says: /dev/sda1: UUID="1fef18d0-e202-4df3-ace8-59e74b0ae3a6" TYPE="ext3" SEC_TYPE="ext2" Though when I try mounting it, the error message is: server01:/home#mount 2d3e150d-a259-4a82-bfe5-f60c6785bc06 /mnt/nfs/backup -t ext3 mount: special device 2d3e150d-a259-4a82-bfe5-f60c6785bc06 does not exist What's going on there?
    – usr2249
    Apr 20, 2013 at 14:53
  • Why you are trying to mount using uuid, first try mounting by short name (eg. sda1 (mount /dev/sda1 /target) Apr 20, 2013 at 14:55
  • Oh, I just took what was written in /etc/fstab
    – usr2249
    Apr 20, 2013 at 14:55
  • server01:/mnt/iscsi_d# mount /dev/sda1 /mnt/iscsi_d -t ext3 mount: special device /dev/sda1 does not exist
    – usr2249
    Apr 20, 2013 at 14:59
  • Any ideas on this?
    – usr2249
    Apr 20, 2013 at 15:19

Solved: The iscsi-nodes weren't set to login automatically. The directories they were mounted to were locked though and couldn't been used to mount other drives there.

How to fix it: Find the nodes your iscsi server provides using open-iscsi (need to be installed):

iscsiadm -m discovery -tst -p [ISCSI-SERVER IP] -d3

Then register them for automatic login:

iscsiadm -m node -T [NODE_NAME] -p [ISCSI-SERVER IP] --o update -n node.conn[0].startup -v automatic

Restart the iscsi service:

/etc/init.d/open-iscsi restart

Use fdisk -l to check if it worked. Should say something like:

Disk /dev/sdc: 323.3 GB, 323384981504 bytes
255 heads, 63 sectors/track, 39315 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Welcome back your once lost iscsi drive. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.