0

I have the following setup.

A physical PC with Windows Server 2012 (host OS) with VMware Workstation 9.02 with:

  • Windows Server 2012 (guest OS)
  • Ubuntu 12.04 (guest OS)

The guest OS's both run as shared VM's with auto start enabled (the reason for running as shared VM's is that this enables the auto start option). The physical PC has 3 NICs.

My ISP provides me with 3 static IPs, one for each NIC (obviously). Using the method described here, I managed to bridge two of the the static IPs to the two guest operating systems. I told Windows to use the other one by default (this also seems to work).

This works fine. They appear to have the right IP addresses (the ones provided by my ISP), and on the host OS I can see that all network traffic from the guests is routed via the correct NIC. Joy!

However, I cannot connect (e.g. with Remote Desktop or with a web browser on port 80) directly to a guest's IP. This is problematic as both guests have to run a web server (both on port 80, so VMware's NAT using only one IP is not an option).

What I've already tried:

  • Disable Firewall on guest and/or host OS: no change
  • Connect to guest OS from WITHIN the host OS (with RDP): works fine (!) This implies that the host OS is blocking something, but where? Strange thing is that disabling the firewall did not help.

Any ideas on how to fix this? All help is appreciated!

  • Not tempted to use Hyper-V? Workstation isn't really a server/serverfault product tbh. – Chopper3 Apr 21 '13 at 22:13
  • I hope to find a solution with VMware Workstation, since other circumstances force me to use Win2012 as host OS. – user1349674 Apr 22 '13 at 7:43
  • But you ARE using it as a host?! – Chopper3 Apr 22 '13 at 8:04
  • That's correct, Windows Server 2012 runs VWware Workstation with the two guests. – user1349674 Apr 22 '13 at 8:11
  • That's why I don't understand your first comment, you can run linux under HV – Chopper3 Apr 22 '13 at 9:05
0

I figured it out.

Having 3 physical NICs is not needed and it confused the routing.

Solution: just 1 physical NIC in the PC, and VMware set to use the MAC addresses provided by ISP. I thought this was impossible as each NIC can just represent one MAC, but VMware takes care of this.

The problem was that since both the host OS and VMware's guest OS use the same MAC, network requests from outside were routed to the host OS instead of VMware's guest.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.