0

I have created an Amazon EC2 instance to host a testlink server with RHEL. I have successfully configured mysql client, Apache and PHP, but when I try to install it and create the DB, I'm unable to reach my RDS instance that will be used to host this Database. I also tried creating the DB manually, but when trying to log in I'm still unable to reach the RDS instance with the following error: "Connect to database testlink on Host xxxxxxx fails DBMS Error Message: 2003 - Can't connect to MySQL server on 'xxxxxxxxxxx' (13) "

Can anyone help me with this problem?

  • Have you checked the security group settings for the RDS to make sure your instance can reach it? – ceejayoz Apr 24 '13 at 15:08
  • I have ensured that the AWS EC2 instance has access to the RDS through security group settings and still unable to reach it from testlink installation page – Luis Montano Apr 24 '13 at 16:13
  • Can you telnet url.of.the.rds 3306? – ceejayoz Apr 24 '13 at 16:17
  • That's strange. I can't telnet the RDS instance. I think it could be related to firewall policies in my company. I'll see if I can get that port opened and it should work. Thanks a lot for your help. – Luis Montano Apr 24 '13 at 17:09
  • But now that I remember. I also tried to connect from my house yesterday and still was unable to connect. – Luis Montano Apr 24 '13 at 17:19
-1

This could related two issues

  • You might not not added your web server IP to the security group in RDS.
  • You might have set the publicly accessible option to NO and in that case you can only access the RDS if your web servers are in the same VPC.
-2

I've struggled with the very same trouble and finally found the answer. Just disable SELinux.

  • Or you could configure SELinux to allow whatever it's currently denying. – Ladadadada Jun 9 '14 at 9:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.