I installed ORACLE/Solaris 11 on my server. After installation I created an additional account for sysadmin. I then did the #passwd -x -1 command for the root role, and my two other user accounts. I did this after the first installation locked me out saying the user account had expired. I've also installed SunRay Server software on the server as well. Anyhow, I rebooted and immediately got the "Account Expired" when trying to login. Any ideas of how to get this problem resolved would be greatly appreciated.


Ah... good ol'Solaris and it's wonderful default policies.

When you created the users on a new system install, there was an account expiration time set. This is in the /etc/shadow file, I believe. You will need to unlock the account and then set an expiration time far far into the future.

I've tried the "never expires" flag in the past, but it's never worked as expected.

You can fix it on a system you've been locked out of by vi'ing the /etc/passwd file after booting into recovery mode. Helps alot if you have a clean working Solaris box you can create a test account and set the expiration flag properly on, and transplant that.

Yes, the above is a bit of a fudge.


Corrected file from /etc/passwd to /etc/shadow.




What does one of the locked accounts look like? (A shadow line, but without the password hash)?

  • 2
    should be in /etc/shadow – kofemann Apr 24 '13 at 18:05
  • ~lol~ My bad. /etc/shadow is the correct file. Updating answer. – Wing Tang Wong Apr 24 '13 at 18:06
  • 1
    Thanks, I'll give this a try and let you know what happens. Again, very much appreciated for the direction! – Shawn Apr 24 '13 at 19:23
  • Not able to boot into recovery mode. Reloaded server. Checked the shadow file and it was commented out correctly at the end. Not sure what's happening. Logged out, tried logging back in with multiple accounts I created and all were expired. – Shawn Apr 24 '13 at 21:44
  • 1
    Wing, I'll try to post if I migrate back to Solaris 11. I back tracked to the latest version of 10. My original reason I wanted to load 11 was I kept getting a EHCI USB 2.0 Error in Vbox for my Windows VMs. I had read that 10 wasn't fully support for Vbox, why, I don't know. – Shawn Apr 26 '13 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.