0

We have a CentOS 6.3 server where we have Installed VMware-Player-5.0.2 for linux 64 bit

When we try to run one of the ".vmx" Virtual machine file using the VMware player, we are getting the following error

Could not open /dev/vmmon: No such file or directory. Please make sure the kernel module 'vmmon' is loaded

What could be the reason? Could you people suggest us on how to start the VMware player to open the virtual machine

Thanks!

0

Well, it seems like the vmmon kernel module is not loaded ;-)

So try 'modprobe vmmon' (as root) and if that doesn't work, it might be worth firing these two:

sudo mv /usr/lib/vmware/modules/binary /usr/lib/vmware/modules/binary.old sudo vmware-modconfig --console --install-all --appname="VMware Player" --icon="vmware-player"

(found that in the VMware forums BTW)

  • "modprobe vmmon" doesn't work & I executed the next two commands the output is: Starting VMware services: VMware USB Arbitrator [ OK ] Virtual machine monitor [FAILED] Virtual machine communication interface [ OK ] VM communication interface socket family [ OK ] Blocking file system [ OK ] Virtual ethernet [ OK ] Unable to start services – Big Data Apr 25 '13 at 9:12
  • # service vmware status Output: Module vmmon not loaded Module vmnet loaded – Big Data Apr 25 '13 at 9:16
0

If secure boot is enabled on your host, it is not allowed to load any unsigned drivers. Therefore, vmmon and vmnet modules cannot be loaded. This prevents virtual machine to power on.

To fix this, you will have to generate a key pair using the openssl to sign vmmon and vmnet modules:

$openssl req -new -x509 -newkey rsa:2048 -keyout VMK.priv -outform DER -out VMK.der -nodes -days 36500 -subj "/CN=VMware/"

(Use any name you want instead of VMK.)

Sign the modules using the generated key by running these commands:

$sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./VMK.priv ./VMK.der $(modinfo -n vmmon)

$sudo /usr/src/linux-headers-`uname -r`/scripts/sign-file sha256 ./VMK.priv ./VMK.der $(modinfo -n vmnet)

Import the public key:

$mokutil --import VMK.der

Confirm a password and reboot your machine. Follow the instructions to complete the enrollment from the UEFI console.

  • Do you mean secure boot? – Michael Hampton Jun 12 at 6:40
  • Yes, that is what I meant. – Overmind Jun 12 at 10:38
  • In that case, it's a good idea to edit the post, to eliminate any confusion. You can do that with the "edit" link at the bottom of the post text. I've made that edit for you on this post. – Michael Hampton Jun 12 at 15:37
0

The vmmon module provides the VMware hypervisor to the system. But it cannot load if another hypervisor is already loaded.

Usually this is KVM. Check to see if the modules kvm or kvm_intel or kvm_amd are loaded. If they are, you should stop any virtual machines, stop the libvirtd service, and then unload the modules.

It could also be VirtualBox if you had that installed. In this case, stop its virtual machines and services, and unload its modules.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.