2

I've been trying to get my LSI SAS 9211-4i moved over to IT mode. But I cannot for the life of me get it erased so I can flash the IT firmware to it.

I've tried using FreeDOS (from the website) and FreeDOS off of UBCD (tried every single different boot option) but they all give the error: Failed to Initialize PAL. Closing program.

I've tried it on my ESXi server, but when trying to erase it, it fails and says it "Failed to Erase Flash. Resetting Card"

Tried it on Windows, but it says it can't do it in this platform. I've even tried to install the MegaRAID Storage manager but couldn't get it to flash to the IT firmware.

I've tried to get my machine to do a UEFI boot to try it that way, but I can't. Has anyone had any luck on a Sabertooth 990fx board to get it to boot to a UEFI shell? I'm also confused as to what files are needed on a flash drive to boot to UEFI as well.

Any help would be awesome. Thanks.

ps. I have the links to the Firmware drivers (here).

1

I was able to get my Saberthooth 990fx to boot to a EFI shell.

If anyone is wondering how I did that, this is what I did.

  • formatted a usb flash drive as fat32
  • copied shellx64.efi, sas2flash.efi, firmware and bios files to the drive
  • Booted to the bios and went into advanced mode.
  • In the boot area, I changed the Secure boot option to OtherOS
  • Then I saved and reset the system
  • Booted back into the bios then in advanced mode, then where you save and reset there is an option to boot to EFI shell, I hit that and it came up to the shell.
  • I then change to fs0 by typing 'fso:' then ls to view the files.
  • I then was able to erase and flash the card(sas2flash.efi -o -e 6 then sas2flash -o -f ####it.bin -b mptsas2.rom)

All is well now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.