I've added a new domain user - who is a member of the "Remote Desktop Users" group, but they are unable to log in to a domain member.

The error in event viewer is

Account For Which Logon Failed: Security ID: NULL SID Account Name: myaccount@mydomain.local Account Domain:

Failure Information: Failure Reason: Domain sid inconsistent. Status: 0xc000006d Sub Status: 0xc000019b

The client just gets "credentials did not work"

Any ideas?

  • Have you tried logging in using format DOMAIN\username as well? Verified that the user is a member of the local "Remote Desktop Users" group on the domain member they are logging into (ie not the Domain's Remote Desktop Users Group)? – floyd Apr 27 '13 at 19:07

Are they new virtual machines, poorly sysprepped? You could be running into this:


I did deploy virtual machines from a poorly configured template and ran into this problem straight away, and reinstalled everything from scratch and it worked. But I'm not convinced about the explanation because of Mark Russinovich from SysInternals's explanation on why duplicate SIDs ought not to be a problem.

| improve this answer | |

It looks like this issue related to trust between the server the your domain... As troubleshooting steps try these

  • Try creating a new user in AD and add the user to remote desktop users, then try to logon using that account.

  • unjoin this server from domain and rejoin it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.