I'm using NSClient++ on the Windows servers and all other checks are working fine. I'm using the default nt_check config, but these show up as "services unknown"

define service{ use generic-service host_name winserver service_description C:\ Drive Space check_command check_nt!USEDDISKSPACE!-l c -w 80 -c 90 }

Does anyone know what I'm doing wrong or can suggest a better nt_check?

  • my final solution to this problem was to use NRPE (check_nrpe) to check the free disk space and not use check_nt Of course this isn't working for all of my Windows servers (on one network all the disk checks timeout), but I suspect that is router/firewall issue – PSXotaku May 25 '13 at 12:10

I was with same problem. My solution was put password in NSC.ini(remove ; on password-secret-password) and put same password in file commands.cfg (check_nt) use parameter -s YourPassword in end of the line command_line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.