This one is really driving me nuts...

For one of our customers, we are allowed access using the Microsoft Unified Access Gateway, which provides an HTTPS-tunneled way to (among other things) run Remote Desktop (RDP) towards their server(s).

This works well for me except for one slight caveat: I cannot, by any means, get the clipboard working.

(The server is btw Windows 2008 R2.)

I've tried all the standard measures:

  • Opening up mstsc.exe and ensuring that the Clipboard box is connected (which it is), connecting to a remote server (veryfing that copy/paste works)
  • Running rdpclip manually on the server (it closes down immediately).
  • Testing my account on a colleague's machine (running Windows 7 as client, straight on the metal - no virtual machine involved there) - working absolutely flawlessly.
  • Testing in numerous different virtual machines myself (Windows 8, three different Windows 7 machines). Always the same issue.
  • Logged off my other user account on the host (Mac OS X), to check if that would help.
  • Rebooted the host.
  • etc...

I'm quite out of ideas. What I did find out is that the .rdp file generated by iexplore/mstsc (in C:\users\plundberg\Local\Temp) incorrectly contains the redirectclipboard:i:0 setting, which is the reason why I cannot start rdpclip.exe manually, and the reason that clipboard redirection is malfunctioning. But why???

This is truly driving me nuts, so... let's hope we have someone out there who has seen the same issue and solved it already. 1000 thanks in advance!

1 Answer 1


Posting my own answer since I found it a while after posting...

It turned out that UAG checks the antivirus installed on the machine. I used to have Windows Defender only, which obviously wasn't considered "good enough". When I installed Symantec Endpoint Protection (which my colleagues were using), it started working instantly.

Thank you for that, Microsoft/whoever. 2 hours of debugging later. But nonetheless, it's quite nice to have it working now. :) :) :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.