1

I am having an issue which there must be a simple solution I am not seeing, but I have googled and googled to no avail.

The issue I am having is when I do a server (physical machine) restart, every time Apache tells me that /tmp/apache2-gbd-dump doesn't exist and to check the httpd.conf file. Well I check the conf file, and sure enough it's calling to a /tmp/apache2-gbd-dump for Core Dump. The issue is this file does not in fact exist. When I look at the logs, that is the only warning/error that is associated with the start failure.

So I've tried to create the file, chown it to www-data:www-data and chmod it to 777. And this works, in that I can now sudo service apache2 start. As soon as I restart the physical machine, the Core Dump file disappears, and I have to recreate the file again manually to get Apache to start, since it fials it's automatic start up. This obviously will not work when this turns into a production server. Has anyone any insight as to what I can look into to find out why this is happening? Here is the code inside the conf file if anyone sees a pertinent issue, can you please point it out?

CoreDumpDirectory /tmp/apache2-gdb-dump

LockFile ${APACHE_LOCK_DIR}/accept.lock

PidFile ${APACHE_PID_FILE}

Timeout 300
KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 5

<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

<IfModule mpm_worker_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

<IfModule mpm_event_module>
    StartServers          2
    MinSpareThreads      25
    MaxSpareThreads      75
    ThreadLimit          64
    ThreadsPerChild      25
    MaxClients          150
    MaxRequestsPerChild   0
</IfModule>

User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}
AccessFileName .htaccess

<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
    Satisfy all
</Files>

DefaultType None
HostnameLookups Off

ErrorLog ${APACHE_LOG_DIR}/error.log
LogLevel warn

Include mods-enabled/*.load
Include mods-enabled/*.conf
Include httpd.conf
Include ports.conf

LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

Include conf.d/
Include sites-enabled/
2

I think that your /tmp is a tmpfs mount. You need to change the core path to be in /var or somewhere else.

See core_pattern in the man core page.

| improve this answer | |
  • Good point ... I will check that and post back ... – Zak Apr 30 '13 at 20:57
  • 1
    Even if it's not /tmp may be cleaned automatically on boot. – rvs Apr 30 '13 at 21:08
  • Turns out it is a mount point for this install, and thus was being cleaned out and files recreated on start-up. Thank you for your help! – Zak Apr 30 '13 at 22:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.