I am attempting to transfer a 1.3GB file from my local machine (Windows 8) to my local hyper-V instance (Windows 2012). The transfer begins at about 300kb/s and then swiftly drops to 12-20kb/s.

The two machines are connected to the LAN via the same physical ethernet adapter. The vSwitch and my local connection are bridged, so the VM and my local machine have IP addresses on the same subnet.

Could that be related to the issue? I not a network administrator by trade so I am unaware of the tricks to diagnose this issue.

  • 1
    What's the NIC chip on the Hyper-V machine? If it's cheap/crappy (eg Marvell, Realtek, nVidia) there's your problem. If it's something good (eg Intel, Broadcom, QLogic, Emulex, Mellanox, Netxen, etc) have you followed the manufacturer's recommendations for Hyper-V (eg disabling: TCP Offloading, TCP Chimney, Large Send Offload, etc - these are the most common culprits, follow directions if they're provided). Also, are you running the most recent firmware (motherboard, NIC, etc)? – Chris S May 9 '13 at 12:49

Most likely, you are seeing an issue with Virtual Machine Queues.

If you are running a Broadcom network adapter, you will need to disable Virtual Machine Queues. We just setup a new server, running Server 2012 Standard with Hyper-V, running two Server 2012 Standard guests, and saw the exact same thing you are describing. This seems to be an issue affecting Broadcom adapters.

Go into the Hyper-V host network properties, and look at the physical adapter, not the vEthernet. On the Advanced tab, scroll down to Virtual Machine Queues, and set it to disabled.

Once we made this change, things were flying.

| improve this answer | |
  • I wish I had seen this post months ago, we were having serious transfer speeds on one of our server VMs and this did the trick. Much appreciated!!! – Jose Jun 8 '15 at 2:59
  • I tried that with no success in the Hyper-V that comes with Windows 10. – sw. Sep 12 '15 at 21:29
  • I don't have that option on mine, even though I'm seeing the same problem and using the same adapter. – NickG Jan 11 '17 at 15:43

I had the same issue when running Hyper-V on with Broadcom NetXtreme I network adapters. I changed out the NICs to Intel and the network started to work as it should.

Here are the steps to diagnose the problem:

  1. Measure current transfer speeds.
  2. Install a Legacy Network adapter, remove the previous NIC on the guest VM.
  3. Measure transfer speeds again.
  4. If you find that there's a significant difference in speed (faster), it is your NIC.

In my case, I have tried different settings on the Network card before changing it out to an Intel. FYI, The Broadcom NetXtreme II network adapters works fine.

| improve this answer | |
  • I have Qualcomm Atheros AR8171/8175 PCI-E Gigabit Ethernet and it has the same issue. – Apache Oct 1 '17 at 10:31

OK, I had the problem of a comatose "local" copy from my Win7 32bit hyperv install hosted on Win8.1 64 bit.

Copy to any other share on the network was fine.

Changed the network inside the VM to use only IPV4 as it had defaulted to IPV6, and speed is now as expected

| improve this answer | |

Your VM have a dynamic disc? If yes, this disks always are more slowly than a fixed disk.

If you like that the information copied go faster, you can try to copy the file with the virtual internal IP.

When you use a Hypervisor (Hyper-V, VirtualBox, VmWare, etc..) you can create a local network between your machine and your VM.

This local network is more fast than normal network and not used the lan cards.

| improve this answer | |
  • a Probably, the problem is a mixed: Dynamic disc, use the same lan card, use the same disc to write and read, etc.. If you use Hyper-V, i made a manual for tunning Hyper-v! monimandarina.blogspot.com.es/2012/04/… This manual is in spanish, you can translate with google translate.h! – madrikeka May 10 '13 at 12:51
  • 1
    Eh, I use dynamic disks and easily get 20-40MBps - there's a speed penalty from fixed, but it isn't that much. Using the IP really wont make a lick of difference in transfer speed. Even if it is using separate NICs across the LAN, there's no excuse for 12-20 kbps. That's dial-up modem speeds. – Chris S May 10 '13 at 13:59
  • Maybe a problem read/write? or antivirus/firewall/others..? filtering traffic something? Can you try to copy a big file in different sites in your virtual 2012 server and see the speed? It is a difficult problem and not easy to find the solution – madrikeka May 13 '13 at 9:28

Check that no other guests have the same MAC address.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.