We have a customer with a server (Win2k8R2) we'd like (and have to) access. On that server our IP is set as an allowed incoming connection.

The problem is that out of 7 computers in our own network this connection is only possible on 5, it fails on 2 (with same credentials).

Out of that 5 that can connect, one is the strangest, an internal server: if I remotely connect to it with my credentials and I use RDP to customer server, it doesn't work. However, if I use other credentials, I can use RDP from there (both users are admin).


1,2,3,4 --> SRV :ok

6,7 --> SRV :fail

6, 7 --> 4 --> SRV :ok with user x

6, 7 --> 4 --> SRV :fail with user y

I haven't managed to find out what is the reason for this and how could I set or ask to be set in order to access that server from all computers inside our network witk permitted IP.

PS. I have read several threads on it and I've seen only one similar (but not same) problem - without solution

  • Is OS and/or RDP client version the same on all the 7 computers? If not, maybe the server could be configured to accept only remote connection from computers with Network Level Authentication. – Emyl May 3 '13 at 12:32
  • OS are different, however, that still doesn't explain why does RDP work from the same computer with one windows credential and not from the other, the HW/SW environment is the same there. In the mean time, thanks for the NLA tip, I will look into it. – csikiati May 3 '13 at 13:04
  • Are these domain based accounts? Are there GPO's involved.? Need more details about the enviro. – tony roth May 3 '13 at 13:29
  • yes, the final accounts used to reach the server are domain based, not yet sure about GPO's there – csikiati May 3 '13 at 13:56
  • also what vpn solution is in place, do you get an access denied or just no connection? – tony roth May 3 '13 at 14:30

Once again, trivial error, it is wort checking and double-checking the IP address and port. That was the problem. Solved with an extra amount of scrutiny.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.