hope you guys can help me find out a solution to this problem that's causing me headache.

My company has a number of front end servers based upon Debian Squeeze, we also set up a local repository into the server lan for those packages that we need to backport or recompile for our own usage.

That's the problem, of all of the 14 front end servers there's only one that freezes during the packages download from the local repository.

I did every kind of test that popped into my brain:

Manually wget the package from shell: OK

Lynx browsing of the repository and download of a package: OK

Scp'ing a package from the repository: OK

Restarting apache on the repository server: Didn't helped me.

Tried to set the HTTP/1.1 pipelining to 0 into apt-get: Didn't helped.

Seems that the problem is only related to the apt-get, but how?

I really hope you guys have an idea, i'm thinking to schedule a server reboot, but it's a production machine so this is not so easy.

Thank you all in advance

  • Did you try "apt-get clean"? May 3 '13 at 16:14
  • apt-get outputs something? you can try debug options on apt.conf
    – Lluís
    May 3 '13 at 17:43
  • Danila, yes i did. @tictacbum nothing but the normal output,hanging on "waiting for headers". Didn't found a suitable debug option though May 3 '13 at 19:35
  • can you paste the source.lst?
    – Brigo
    May 3 '13 at 22:38
  • brigo i don't think the problem is into source.list, because i know that the server has some problem towards our local repository, but i can't figure it out, btw here it is pastebin.com/WiyS7Y5P May 6 '13 at 8:01

Have you tried capturing packets? It should give you some information on connection status, as this usually indicates network problems.

As an example, here's the output for a successfull package install:


GET /ubuntu/pool/universe/s/sdl-image1.2/libsdl-image1.2_1.2.10-3_i386.deb HTTP/1.1

Host: archive.ubuntu.com

Connection: keep-alive

User-Agent: Debian APT-HTTP/1.3 (0.8.16~exp12ubuntu10)


HTTP/1.1 200 OK

Date: Fri, 24 May 2013 13:53:57 GMT

Server: Apache/2.2.22 (Ubuntu)

Last-Modified: Fri, 30 Dec 2011 01:03:31 GMT

ETag: "71c6-4b544cd24fec0"

Accept-Ranges: bytes

Content-Length: 29126

Keep-Alive: timeout=5, max=100

Connection: Keep-Alive

Content-Type: application/x-debian-package


Is there a apt-cacher proxy declared in the Apt configuration? Check, if the following file exists:


See if it points to a server that can't be reached. That would explain the timeout. That happened to me, when I forgot I'd set it up.

Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.