I have a ubuntu server(host), and a windows 2008 r2 server(client) virtual machine on it.

All my IIS based sites are located on the host machine, in a location which is shared with the client vm.

I have a reverse-proxy setup to direct the sites to their proper locations, and one site setup in IIS (currently).

On initial setup, I had this site located on the C drive of the virtual machine, and was serving it from there with no issues.

Once I change the location to the shared folder, I come up with 500.19 error. I tried adding the IUSR account permissions on the folder, but I do not think they took, since the folder is a location on the ubuntu host machine.

I have also tried to change the application pools Identity to NetworkService (as suggested on other sites), and have even added the 'Everyone' account to the share, but still get the 500.19 error page.

Any thoughts how I can do this? I sort-of 'need' to do this, because I would like to keep the size of the vm down, thus the need for the network shared off-load. I think it's a conflict between Windows user accounts on the VM, and Linux user accounts on the host, so if I can get even one account to mesh that will work, without messing up the sites currently hosted through Apache on the host would be great!

  • i've tried changing the owner of the shared directory and setting chmod as well, but still the same error. – Kevin May 6 '13 at 18:04
  • in the windows vm, I try to add IUSR, and the NetworkService accounts, but they disappear. I assume this is because they aren't UBuntu users? – Kevin May 6 '13 at 18:05

The reason you're encountering this error is because IIS is expecting to be able to read/set Windows extended attributes on the directories and files as part of it's security settings.

I'm assuming you're using VMWare for the virtual machine hosting solution and that you're using it's shared folder feature to make a Linux directory appear as part of the file system in Windows. When using this method Windows thinks that directory is part of it's regular fully controlled file system and doesn't know better.

So on too how to solve it... Unless there is a way to disable those security checks (and I'm not sure there isn't) there isn't anyway to accomplish what you want using the Shared folders features, however, you have other options.

The two easiest that I can think of is either host the directory from the Ubuntu machine as a samba share and mount it in the VM as a remote share, or export the directory as an NFS share and use Windows 2k8's support for NFS to mount it as a remote share. You might encounter the same issues you are now with the samba export but I don't think Windows will have any of the same expectation with the exported NFS share.

  • 1
    host the directory from the Ubuntu machine as a samba share and mount it in the VM as a remote share this is what I am currently doing, and using Qemu/KVM, not VMWare – Kevin May 10 '13 at 12:21
  • so, i wonder if I use virt-managers shared folder if it'll make a difference... b.r.b. – Kevin May 10 '13 at 12:25
  • no difference... – Kevin May 13 '13 at 11:47
  • No difference with virt-manager's shared folder or with a samba share? All shared folders into VMs are going to behave the same way since they don't actually share the same filesystem type. – TrueDuality May 13 '13 at 19:28
  • no difference... – Kevin May 14 '13 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.