Just installed SQL Server 2012 Enterprise on my work machine, and I'm unable to connect to my local instance (MSSQLSERVER). I get the "Login failed..." message.

I enabled the SQL Server Browser service, and have tried many different combinations of logins, using both Windows Authentication and SQL Server Authentication, and nothing seems to be working.

Per some previous suggestions, I've tried disabling all services except "SQL Server (MSSQLSERVER)" and then restarting "SQL Server (MSSQLSERVER)", and that didn't work. I've tried running SSMS as Administrator, and that didn't work. I've tried "Repairing" my SQL Server install using the install CD, and that didn't work either.

Any suggestions?

  • Have you looked at what protocols are enabled; TCP/IP, Named Pipes, Shared Memory?
    – joeqwerty
    Commented May 7, 2013 at 15:01
  • How can I verify which protocols are enabled/disabled? EDIT: In Configuration Manager, Named Pipes were disabled. I enabled it and restarted the SQL Server instance and am still unable to connect Commented May 7, 2013 at 15:25

2 Answers 2


Gary, the part of SQL Server setup you need to look at is as follows. Make sure you record what users and groups are in the Specify SQL Server administrators section.

enter image description here


If you can't get in with Windows authentication most likely you didn't provision any Windows accounts during setup

It used to be that the builtin\administrators group was automatically provisioned with the sysadmin role but that changed in SQL 2008 and you now need to manually provision Windows accounts / groups either during setup or post-installation.

It's likely that you'll need to log in using the builtin sa account and set up your authentication as sa. If you've tried logging in as sa and are still getting an error then it's probably a transport issue. If this is the case can you post the detailed error message you get?

Based on your comments, check your server and client transport settings to make sure the protocols are enabled.

In SQL Server Configuration Manager:

  1. Expand SQL Server Network Configuration and click Protocols for MSSQLSERVER
  2. Check that Shared Memory is enabled
  3. Expand SQL Native Client 11.0 Configuration and click Client Protocols
  4. Check that Shared Memory is enabled

You will need to restart the SQL Server service if you need to change the SQL Server Network Configuration settings.

  • When I try to connect using my computer name as the server name, using SQL Server Authentication, with "sa" as the login (no password), I get "Login failed for user 'sa'". When I first tried using login = "sa" with my machine's password I use for logging in, I got an error, something along the lines of "Able to connect but experienced a transport error". Now when I try the same thing I get "Login failed for user 'sa'". It seems that transport error was a one time thing. EDIT: closed SSMS, reopened, tried logging in with "sa" and local password, got that error message again: Commented May 7, 2013 at 15:09
  • The sa password won't be blank, and it won't be the same as the password you login to your machine with. The sa account is a SQL Server specific account with its own password. You would have set this password during installation. That's the password you need to use.
    – squillman
    Commented May 7, 2013 at 15:12
  • "A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233) --> No process is on the other end of the pipe" Commented May 7, 2013 at 15:13
  • I never set any sa password during the installation process Commented May 7, 2013 at 15:14
  • "No process is on the other end of the pipe" - is the SQL Server service started? Also, are you saying that you left the sa password blank during setup?
    – squillman
    Commented May 7, 2013 at 15:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .