1

I recently looked into replacing my Netgear VPN router with a Linux machine. I have configured it and everything worked perfectly including port forwarding. Except that when I tried to connect to a web hosting company's PPTP server, it failed with error 619. The previous router has no such issue.

I tried to connect another PPTP server (running on Linux) and it connected successfully.

In the Linux router, I forwared 1723 and gre to an internal PPTP server. I thought that they are only needed for incoming PPTP connections not for outgoing..

2

PPTP is one of those modules that you have to make sure a particular netfilter module is loaded for to permit it through a NAT.

Make sure nf_conntrack_pptp, and nf_nat_pptp. are loaded (check with lsmod, load with modprobe).

1
  • Timely advice. After loading the modules it worked. Thanks – cuteCAT May 9 '13 at 0:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.