0

I'm trying to setup an FTP server so that any machine on the network can upload files to my /var/www/ on my Ubuntu 13.04 LAMP server -- with or without authentication.

I've spent most of the day trying to achieve this, to no resolve. I am ready for a fresh approach...

I've tried using vsftpd and proftpd + gadmin-proftpd -- details, below..

But the issue seems to be that I cannot find a way to get write privileges on /var/www/ via a remote computer. I can ssh in, but when accessing files via nautilus, sftp://[server.ip] - I cannot copy --


The following may be irrelevant: vsftpd.conf has all the things it should - anon_enable and the like, but I can not write files to the server from the client.

proftpd does similar, although I set up an ftpuser + password which it does not accept. In spite of passing the connection test, the client machine still cannot write to the server's /var/www/

SO - since all I am looking to do is use this as a LAN-Only FTP -- perhaps there is another solution that I have not come across, yet.

I've tried some odd dozen tutorials on both vsftpd and proftpd to no avail--

Any advice on this matter would be highly appreciated.

  • 1
    If you have iptables enabled you would need the IPTABLES_MODULES="ip_conntrack_ftp" – Vick Vega May 9 '13 at 0:33
  • Thanks- I did, at one point, try $ modprobe ip_conntrack_ftp - However, I don't believe a firewall is the issue, as opening a browser to "ftp://[server's-ip]" -- accepts the server's sudo-username and password -- – rm-vanda May 9 '13 at 0:37
0

I solved this with the following:

  1. Abandon all ftp server programs--- openssh-server includes sftp
  2. Add authorized user, make sure mode and ownership is correct:

    useradd -G www-data ftpuser

    chmod 775 /var/www/

    chown -R ftpuser /var/www/

  3. sftp ftpuser@server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.