I'm trying to use MDT and WDS to image a machine.

I've got the image of the reference cpu via a vmware machine.

I tried running LiteTouch via PXE on the target machine. It gives me an error:

A connection to the deployment share (\share\deploymentShare$) could not be made. The following networking device did not have a driver installed. PCI\VEN_14E4&DEV_1692&SUBSYS_04001028&REV_01.

I check OOB and didn't see a matching driver. I grabbed the OEM disk and pulled the drivers off and imported them into OOB. In OOB, I can find the driver, and in details > supported pnp id's can see


I updated the deployment share, both with optimize and completely regenerate boot images. I created a new task sequence. I proceed to reboot and run LiteTouch on the target to be met with the same error.

I also verified that this PNP ID is in DeploymentShare\Control\Drivers.xml

Isn't the point of OOB to have the drivers you need for the boxes you are deploying to?

Is there something else I'm missing?


  • 1
    Did you replace the boot images in WDS with the newly regenerated images from MDT? This must be done manually in WDS. – dwolters May 10 '13 at 19:09
  • Um, no. I thought the litetouch instantiation pulled whatever drivers it needed. So you're saying after updating the deployment share, I need to go into WDS, delete the old boot image, and replace it with the new one? edit: yup that did it. Can you add this as an answer so I can accept? Thanks for the help. – stormdrain May 10 '13 at 19:18
  • Great! Answer posted, glad you have this issue resolved and glad I could help. – dwolters May 10 '13 at 19:47

When you regenerate the boot images in MDT, you must replace the existing boot images in WDS with the newly created images. The drivers are injected during the regeneration process, which is different than how it works with the install images.

More information about deploying Windows with MDT and WDS can be found on the Springboard Series pages on TechNet.


I just ran a test to verify adding a driver to a boot image. It has been some time since I needed to since I've moved on to SCCM 2012. First you need to add the driver to your "Out-Of-Box Drivers". You then need to right click your deployment share and select properties. Select the tab "WinPE" and make sure the second radial button (Include only drivers of the following type) is selected and the top two check boxes (Include all network and include all mass storage). After you do that update your deployment share and you should see the driver get injected into your boot image.

  • Thanks. However, the default is as you advised; second radial and first two checked (net and mass storage). Both x86 and x64 – stormdrain May 10 '13 at 19:04
  • Have you updated the Deployment Share and verified the driver is being injected? – user2258863 May 10 '13 at 19:35
  • Yes. The issue was that I didn't add the newly created boot image to WDS, which in retrospect, makes sense. Thanks again for the help (and for going so far as to test) -- it's appreciated. – stormdrain May 10 '13 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.