I just got myself an unmanaged Dedicated VPS from OVH and I don't have a prior experience of setting up servers or DNS servers but I followed a couple of tuts and installed webmin and created NS Zones for my Domain but now I'm having a weird issue where mxtoolbox and intodns.com are saying that no NS records are found for my Domain although I did register ns1.example.com and ns2.example.com with my domain registrar (which is Network Solutions in this case) but it still keeps failing and I am unable to access the website. I have been looking for a solution for 2 days now and I still haven't gotten one. Also, I am using CentOs 6.3. Here is my BIND config which I got from Webmin

// named.conf
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
// See /usr/share/doc/bind*/sample/ for example named configuration files.
options {
listen-on port 53 {; 198.245.51.xxx;};
listen-on-v6 port 53 { ::1; };
directory   "/var/named";
dump-file   "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    memstatistics-file "/var/named/data/named_mem_stats.txt";
allow-query     { localhost; any; };                      ## IP Range ##
allow-transfer  { localhost; 198.245.51.xxx; };                        ## Slave     DNS IP ## 
recursion yes;
dnssec-enable yes;
dnssec-validation yes;
dnssec-lookaside auto;
/* Path to ISC DLV key */
bindkeys-file "/etc/named.iscdlv.key";
managed-keys-directory "/var/named/dynamic";
forwarders {
logging {
    channel default_debug {
            file "data/named.run";
            severity dynamic;
zone "." IN {
type hint;
file "named.ca";
include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";
zone "example.org" {
type master;
file "/var/named/example.org.hosts";
allow-transfer {
also-notify {
zone "" {
type master;
file "/var/named/198.245.51.xxx.rev";

My IP table rules:-


My hosts file:-

Do not remove the following line, or various programs
that require network functionality will fail.       localhost.localdomain localhost

198.245.51.xxx  ns1

198.245.51.xxx  example.org

198.245.51.xxx  ns1.example.org

198.245.51.xxx  ns1.example.org.

My resolv.conf file:-

namserver 198.245.51.xxx
ns1.example.org 198.245.51.xxx
ns2.example.org 8.33.137.xxx
nameserver 213.186.33.xx
search ovh.net

intodns.com results:-


Note:- Just in case there is any confusion regarding the domain example.org, I just use this alias to mask my domain name but I'm pretty sure you guys already figured that out so just putting it out there.

Thank you very much for your reply!


My Zone File:-

$ttl 38400
example.org.    IN  SOA ns1.example.org. admin.example.org. (
        38400 )
example.org.    IN  NS  ns1.example.org.
example.org.    IN  A   198.245.51.xxx
www.example.org.    IN  A   198.245.51.xxx
ns1.example.org.    30m IN  A   198.245.51.xxx
example.org.    IN  NS  ns2.example.org.
ns2.example.org.    IN  A   8.33.137.xxx
198.245.51.xxx.example.org. IN  PTR ns1
198.245.51.xxx.example.org. IN  PTR example.org

My Zone overview:- Zone
Zone: Root zone Type: Root Zone: 0 Type: Master Zone: 0000::1 Type: Master Zone: Type: Master Zone: 198.245.51.xxx Type: Master Zone: localhost Master Zone: localhost.localdomain Type: Master Zone: example.org Type:Master;

My dig results:-

[xxxx@xxxxxx ~]# dig ns1.example.org

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> ns1.example.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19537
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;ns1.example.org.            IN      A

ns1.example.org.     1800    IN      A       198.245.51.xxx

example.org.         38400   IN      NS      ns1.example.org.
example.org.         38400   IN      NS      ns2.example.org.

ns2.example.org.     38400   IN      A       8.33.137.xxx

;; Query time: 4 msec
;; WHEN: Sat May 11 23:01:48 2013
;; MSG SIZE  rcvd: 100

Please let me know if you need anymore info.

  • Where is your zone file? – Michael Hampton May 12 '13 at 2:40
  • @MichaelHampton added. please let me know if I can provide you with anything else. – Mr.Flocker May 12 '13 at 2:47
  • That doesn't look particularly wrong. If you really want this solved in any reasonable amount of time, you should probably disclose the domain name. – Michael Hampton May 12 '13 at 2:48
  • Seriously. Obfuscating your domain name and your ip addresses doesn't make anything any more secure. You came here for help so how about helping us to help you by giving us the real domain name at the very least. If you're worried about disclosing your domain name then why register it in the first place? The information you've obfuscated is already available to some parties and will be available to everyone once the problem is solved, so I don't see the point in your not disclosing it in your question. – joeqwerty May 12 '13 at 3:28
  • Right now it looks like Network Solutions is authoritative for your domain. The NS records returned for your domain name are ns19.worldnic.com and ns20.worldnic.com. That's assuming that your domain name is powerbuddy.com. – joeqwerty May 12 '13 at 3:34

You may have a firewall running, and as i remember CentOS's default firewall block port 53 (though i may be wrong here).


allow-query     { localhost; any; };


allow-query     { any; };

maybe that causing some problem. Also delete the :

forwarders {

since i believe that 2 IP is your own IP.

Restart bind, and after restart check that is really running with ps -ef | grep bind .


So when you setup your DNS name server records, there are two components:

1) Glue Record - This is what happens when you register your name servers with the registrar.

2) NS Records - You need to create a dns zone for example.org or whatever your domain is, and create A records for ns1 and ns2, pointing to the IPs that you set in your Glue records.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.