1

I'm setting a few sites up and many email accounts for a new company so I wanted to save some money as I already have a server running Windows Server 2008 R2.

I have a static IP of 80.229.46.115 and the server's IP is configured as 192.168.1.63. The server is at a business address and is using business broadband. Upon asking 123-reg.co.uk to add an A record for my FQA they have informed me I should not be using 192.168.1.63 under IPv4 settings manually and I should be using the actual static IP of 80.229.46.115.

When I try to add 80.229.46.115 under IPv4 it loses connectivity and under the machine's IP of 192.168.1.63 I am seeing the DNS server is running OK.

Is what the rep at 123-reg told me incorrect?

5

Yes, the rep is correct. 192.168.0.0/16 is a private IP range, and isn't available to the public Internet.

What you will need to do is use your public IP in the DNS record and then port-forward to one of your private IP addresses.

My personal advice, though, is to NOT use home Internet/networking for business use. What happens when your home broadband service or phone line goes down? Is your customer happy with having their data hosted on a residential premesis? How good is your home security (as well as your home network security)?

  • Hi sorry I didn't mention this is at a business address and is using business broadband. I am currently looking into some hardware based firewalls, any suggestions? - The title should have been first business server, doh! - PS: I'm not going to be using this for anybody elses businesses but my own until I fully understand the server inside out. – user173421 May 12 '13 at 12:38
  • Also, how do I port forward the public IP 80.229.46.115 to the private IP of the machine within Windows server 2008? – user173421 May 12 '13 at 12:39
  • 1
    You'll need to use NAT (or more specifically Destination NAT or DNAT) to forward the specific ports you require via your router/firewall. Your device's documentation will help you with the exact steps. – Craig Watson May 12 '13 at 13:45
  • Do I need to use two network cards for this, one for LAN and one for WAN as I've just installed Routing and Remote access on the Server but when I go through the steps of configuring and enabling NAT the 'use public interface to connect to the internet' is not allowing the radio button but 'create a new demand dial interface to the internet' is. Thanks for all the help thus far it's much appreciated! – user173421 May 12 '13 at 20:21
  • I did not have to use NAT in the end I could port forward using DMZ in my router 'Technicolor TG582N' - Simply had to open port 80 for applications and then enable the server to bypass the firewall and NAT of the gateway. – user173421 May 12 '13 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.