0

Masters,

I have a mailbox at gmail. (mymailbox@gmail.com) I have a mailbox at Exchange 2010 (mymailbox@company.local)

I set mailforward in Ex2010: every mail forwarded what i got in exchange automatically forwarded to Gmail mailbox too.

If i send an e-mail to my EX2010 mailbox i got it and succesfully forward to my gmail box.

But if i send an e-mail from my "mymailbox@gmail.com" to "mymailbox@company.local" :

  • i got my mail in EX2010 (mymailbox@company.local)
  • but the mail did not forwarded back to my e-mail. (mymailbox@gmail.com)

  • We checked the log files and mail forwarded, but mail never arrived.

  • We asked our ISP and they saw GMAIL receives our mail, but mail never arrived to my GMAIL mailbox.

We just recently changed from exchange 2003 to exchange 2010. And earlier this forwarding is worked well on EX 2003.

What should we configure in Exchange 2010 to work this again? (In the tracking log explorer we saw the mail which was fordwarded send by the same address which is the recipient address. We think GMAIL block this mails 'coz the ISP told us, gmail receive the e-mails with headers "the header maybee modified"..or somethink like that.

Thank you for any suggestion,

  • Do you have copies of the headers? – TheCleaner May 13 '13 at 14:47
  • I can attach you the header but this header only contain the mail way: from gmail to exchange. This header not contain the forwarding back to my gmail. I can't not provide any header from the forwarding process. In the tracking log i see: the recipient and the sender is the same address. (mymailbox@gmail.com) – holian May 13 '13 at 15:42
  • GMail support is available if you are using Google Apps and should be able to provide the headers or you can enable debugging on the SMTP connector to see what the SMTP transmission looks like. If the ISP confirms that GMail is receiving them but either dropping them or treating them as spam, there's not much you can do short of using a different method (like transport rules) to redirect the inbound email to the original exchange mailbox. – TheCleaner May 13 '13 at 16:20
  • we try to make a new transport rule. (this is way cause this..exchangeshell.wordpress.com/2009/09/05/…) So we try this: If e-mail from mybox@gmail.com and sento mybox@gmail.com than modify From to mybox@mycompan.local.. Unfortunatelly i don't know how to use "set value of header". We can use FromAddress and SenderAddress but non of work. – holian May 13 '13 at 17:05
0

Look at Sembee's comments here, specifically about creating a forwarding rule WITHIN the mailbox

This will change the FROM address since it is getting the email and then forwarding it from the mailbox mybox@domain.local

To do this:

  1. Open the mybox@domain.local in Outlook
  2. Create a new Rule
  3. Click Advanced Options or "create a blank rule" (depends on Outlook version)
  4. On "Select Conditions" just click Next
  5. It will say "This rule will be applied to every message you receive. Is this correct?"
  6. Click YES
  7. Check "Forward it to people or public group" and at the bottom click the hyperlink and choose the gmail contact from the GAL
  8. Apply the rule and close Outlook

That should do it...

But if you want to try a transport rule, try something like this:

enter image description here

That might get you what you want.

BTW, why the need (beyond testing) to have an email from mybox@gmail.com simply come straight back to mybox@gmail.com?

  • We have two problem: 1. Sometimes from GMAIL send an E-mail to a group (managers for example.) This group contain many e-mail plus me. I would like to come back this e-mail for me..but this is the smalles problem. I think if somebody reply to all, i think i will got the mail. 2. We try to send e-mail from xy@gmail.com --> mybox@company.local and the autoforward send this mail to mybox@gmail.com but i got warning in gmail "this message may not ....". This is caused because the from and recepient mail the same. (mybox@gmail.com) – holian May 13 '13 at 18:38
  • We try set FromAddress and SenderAddress non of work. I think i tried with From but with this value i can not save the rule. If i edit the subject than i got the mail in gmail (with warning). I think the best solution somehow change the Sender to mybox@company... As work in Exchange 2003. – holian May 13 '13 at 18:45
  • If the transport rule isn't working you'd need to set the rule directly within the Mailbox (as a rule that forwards on to the gmail account), this would make it from mybox@company. Just use a default rule that applies to all emails and then forwards to the external contact. Do you know how to do that part? – TheCleaner May 13 '13 at 19:49
  • I dont really sure what you suggest.. – holian May 14 '13 at 11:17
  • I'll update my answer. – TheCleaner May 14 '13 at 13:02
0

I know this is old. But, you can't send e-mail to yourself in g-mail. A strange, but annoying limitation.

https://support.google.com/a/answer/1703601?hl=en

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.