0

I am running a debian 6.0 open VZ container and can't get my NFS share to mount. The error I am getting is mount.nfs: mount to NFS server '' failed: timed out, giving up

However, using the same exact command in ubuntu 13.04 works. The NFS share is on my FreeNAS and is exported to the entire 192.168.1.0/24 network. I have installed the nfs-common and dependencies on both... Is there anything special with the openVZ containers since they aren't running their own kernel?

EDIT: I am using proxmox 3.0-13 as the container host

1

did you do :

be sure to stop the container first:

vzctl stop <container id>

enable nfs for the container:

vzctl set <container id> --features "NFS:ON" --save

restart the container:

vzctl start <container id>

I run nfs clients on containers all the time with this setup.

Only oddity I find is once in a while the container won't auto mount nfs shares that are in the /etc/fstab

0

You can not use kernel space NFS. Use the user space NFS.

See: http://openvz.org/NFS_server_inside_container#User-space_NFS_server

0

Another option is to mount the volume on the HN and then bind mount it into the container during startup (vps.mount or $ctid.mount) scripts. The mount scripts for OpenVZ are called after the CT directory is mounted but before it is started and don't have anything to do with you making mount commands at that point.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.