I've configured a sample Apache Solr 4.1 installation using this tutorial. The sample http://localhost:8090/solr (changed the port in server.xml) worked and redirected me to http://localhost:8090/solr/admin with some output. Now, I've upgraded to Solr 4.3 by stopping tomcat6, removing /var/lib/tomcat6/webapps/solr.war and solr, replacing the solr.war with the new one. After starting tomcat6, /var/lib/tomcat6/webapps/solr gets recreated. However, http://localhost:8090/solr now throws a 404.

HTTP Status 404 - /
type Status report
message /
description The requested resource () is not available.
Apache Tomcat/6.0.35

It is strange, that it shows no paths, but only when I try to reach something in /solr. When I type in something random, the paths show up correctly in the 404, so something seems to be done by tomcat, but it is not correct.


i ran into a similar problem, it has somthing to do with this: http://lucene.apache.org/solr/4_3_0/changes/Changes.html#4.3.0.upgrading_from_solr_4.2.0 "Slf4j/logging jars are no longer included in the Solr webapp."

you have to do the same as here: https://stackoverflow.com/questions/16415948/solr-4-3-tomcat6-ubuntu-installation-exception

in your case probably: copy all files from example/lib/ext/ to /var/lib/tomcat6/lib/ (lib most likely doesn't exist, so create it)

  • My god, why isn't this documented anywhere. Will test it, thanks! – SebiF May 23 '13 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.