6

We are in the process of migrating a bunch of users' home directories onto a new server running Windows Storage Server 2008 R2.

For most users, this has gone well and our group policy has done its job in redirecting users' My Documents folders to their new network path (\\server\Users\%username%\Work).

The problem is, on a small number of Windows 7 PCs, the Documents library isn't automatically adding the users' redirected My Documents path as it does on other PCs. And when I try to manually correct this by adding the path myself, I get the message "This network location can't be included because it is not indexed."

Windows Search Service is installed onto the server and the Users directory has indexing enabled, so as far as I can tell, the network location IS indexed.

Even if I manually work around the issue and get the users' home directory included in the Documents library, Windows persists in telling me that "Some library features are unavailable due to unsupported library locations".

2
  • This other question is probably the same as mine, but I'm not happy about the resolution. The workaround works, but you've got to do this on a per-user basis. As far as I'm concerned, this functionality should "just work" and although I don't have litterally hundreds or thousands of PCs to apply this fix to, I'd rather fix the cause of the problem than brush it under the carpet. Windows 7 library nightmare May 16, 2013 at 11:19
  • This actually helped me a lot! cloudtec.ch/blog/tech/…
    – Hugo
    Oct 4, 2014 at 20:14

5 Answers 5

5

In order for the Windows Search Service to be able to index a folder/share, the local SYSTEM account requires NTFS permissions on the server.

After setting these permissions, group policy was able to add the users' home shares to the Documents library and I was able to do this manually myself without the message, "This network location can't be included because it is not indexed."

Wouldn't it be nice if an error was logged in the System event log to let me know that Windows Search Service doesn't have the permissions it needs to index a folder?

1

One possible solution is to manually update registry keys which tell Windows where the "personal" folder is located.

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders] "Personal"="\\\\server\\users\\username\\Documents"

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders] "Personal"="\\\\server\\users\\username\\Documents"

I believe these registry keys should be updated automatically when the group policy is applied.

1

I believe you have to allow offline files and have the redirected folders set to "always available offline" for windows search in windows 7 to index the network location. There is, I believe, a patch for windows 7 that allows it to index network UNC paths.

I've seen other reports of people using mklink to a separate directory as a symbolic link to the network location and adding that directory to the library so windows search can index it.

1
  • Hi Rex. Yes, I've read that too. I allowed offline files as well as allowing SYSTEM permission to access the directories. One or the other seemed to improve the situation, so that Windows no longer reports that the location is not indexed. But, then I noticed users with large folders having slow logon/logoff due to offline files synchronizing. So I removed offline files and it still worked. So I'm now thinking that you either have to a) allow offline files so that the users' PC can index the files locally or b) set permissions correctly so that the server can index them. May 18, 2013 at 8:19
1

I may have this sussed now...

The local SYSTEM account did not have any permissions set on the folders in question. I've allowed SYSTEM to have full access, as per this thread. This could explain why Windows is telling me that the directory is not indexed.

I've also changed the Offline files option on the share to allow "Only the files and programs that users specify are available offline" to be cached, instead of disabling offlines files for the share.

The number of files indexed is going up... I'll report back on whether or not this turns out to be the solution. :)

0
-1

Add the Windows Search Service under Roles and Features. Then you will be able to redirect your My Documents to a mapped drive on your file server

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.