1

I want to install php5-mcrypt, but I get this error after entering a

apt-get install php5-mcrypt

Error:

php5-mcrypt : Hängt ab von: php5-common (= 5.3.3-7+squeeze15) aber 5.3.9-1~dotdeb.2 soll installiert werden

Error (translated):

php5-mcrypt : Depends on: php5-common (= 5.3.3-7+squeeze15) but 5.3.9-1~dotdeb.2 should be installed

My sources.list:

# squeeze packages
deb http://ftp.de.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.de.debian.org/debian/ squeeze main contrib non-free
deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main
2
  • apt-get update ? – Remi Gacogne May 20 '13 at 12:12
  • Was the first step. Sorry, I didn't write this. – Mischa May 20 '13 at 12:21
1

It seems you had different repository sources in the past and you tried to install from them:

  • the official Debian repository
  • the unofficial dotdeb.org repository

The php5-common package coming from dotdeb.org is currently marked to be installed, although you don't have the dotdeb.org source present anymore. And the php5-mcrypt package you're trying to install is coming from the official Debian repository and is from an older version, hence the discrepancy.

To solve that, you have 2 options:

  1. You go with the dotdeb.org repository and you add it back to your sources, you apt-get update and you try to install again.
  2. You keep only packages coming from the official Debian repo, so you should prevent the installation of the php5-common (and any other package coming from dotdeb.org or other unofficial repo and marked to be installed). This can be done with apt-get remove php5-common
6
  • Okay. And what happens to the other packages? dpkg --list | grep dotdeb throws: libapache2-mod-php5, php5, php5-cgi, php5-cli, php5-common, php5-curl, php5-gd, php5-imap, php5-mysql, php5-sqlite, php5-suhosin and php5-xsl – Mischa May 20 '13 at 18:12
  • I installed it via dotdeb and made an upgrade from PHP5.3 to 5.4. Thank you! – Mischa May 20 '13 at 19:03
  • If you had multiple packages marked to be installed from dotdeb, you would have needed to remove them all (if staying with official Debian packages only). But in my experience dotdeb packages are quite stable and provide an easy way to have a more up to date PHP. – Tonin May 21 '13 at 11:28
  • @StinsonMaster Can you up vote my answer as it seems it did satisfy you? That usually is the practice on SE. Thanks! – Tonin Jun 17 '13 at 19:15
  • 2
    Yes, but it is not possible to vote if you have less then 15 reputations ;) – Mischa Jun 18 '13 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.