We have a server running 2012 essentials as Domain controller and DNS and a few other bits. But over the last few days suddenly all the client computers on the network have lost Internet connection.

They can still use all the network resources, (file, printer, AD etc) but completely lost Internet. I believe this to be a DNS Error but am not sure.

I say that because running the network trouble shooting it says "unable to connect to DNS server".

I've tried disabling firewalls, checked the forwarders, nslookup seems okay. Even tried restarting a number of services and DNS flush.

But as soon as the server is un-plugged from the network, Internet is restored to all the clients.

Plug it back in again and Internet goes. All the clients are using the correct DNS server when doing ipconfig /all.

What could it be?

  • It sounds to me like the server you are unplugging is using the same IP address as your gateway, causing an IP conflict to which the server wins and the gateway loses. Then your clients start trying to get internet access through the non-gateway server. Do an ipconfig /all on the server itself and see if any of its IP addresses are the same as the gateways. May 20, 2013 at 23:43
  • How does nslookup seem okay? What is the result? Which DNS server are you referring to as the "correct" one? May 20, 2013 at 23:43
  • Thanks Mark Henderson !!! If your ever dorset way give me an IM and il buy you a pint. It did turn out to be a problem with the gateway. It wassent that it was the same address. The gateway was a compleatly diffrent range. When the problem first started that was one of the first things i checked, and then ruled it out as there was actually a problem with DNS. But the problem persisted. Some doungut kept hard resetting the router and thus resetting its range to 192.168 insted of 10.0. Thanks again for all your help. Lee
    – FuzzyPeach
    May 21, 2013 at 13:33

1 Answer 1


You might have an issue where you have the wrong forwarders set in your servers DNS. Essentials does not update the forwarders after the server is initially setup so you might have the wrong name servers listed in there.

Double check that your forwarders match the dns servers on your router.

If you have connected the client machines using the connector they will use the Lan Configuration Service to set your dns on your adapters to the IP of the essentials server, this is how the server gets away with a dynamic IP. It also has a fallback that if the server cannot be contacted it will revert your dns to what is served by dhcp, that is why it works when the server is disconnected.

I just encountered this issue where the server was installed on one ISP and then moved on site. The name servers for the one ISP would not resolve on the server in the new location, hence internet died. You could reset the dns on the adapters but eventually the connector would reset it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .