0

I am currently running a local DNS server which is configured with one domain controller, having a bunch of domains and those domains have all wildcard entries for any subdomains. I also have WINS enabled for easy file exploring.

My problem that I am having at the moment is that these domains and subdomains do not seem to function (cannot ping them) after a while; when I do ipconfig -release & -renew on the client computer however, I am able to connect to the (sub)domains again for a period of time.

Could this be because I have set-up Google DNS as a secondary DNS server for everything apart from my local domains?

I am running DNS server on a Windows Server 2008 R2 server and IIS on a seperate Windows Server 2003 server which has the actual websites associated with the domains.

I'd also like to note that I seem to be also having the same issue as https://serverfault.com/questions/508571/dns-cache-in-windows-client-not-updating, maybe this is related to this issue?

3

DNS has been designed to function with a single, world-wide unique naming space. If you have set up your wildcard subdomains on your internal name server only and did not set up delegations from the public naming space, you cannot configure your clients for public name servers and expect them to resolve your internal-only domains.

The way DNS resolution works, the client sends its request to a name server and as long as it gets any valid response (even if the response is "no such name"), this response's data is used. Other name servers only would be queried if the originally queried name server failed to produce a response at all within the timeout period. This is also what you likely see happening - your clients start querying the wrong (public) DNS server where the only information about your internal subdomains which can be retrieved is that there is "no such domain". Re-applying for the IP address resets the DNS client state and internal servers are queried again, returning the desired addresses for your name queries.

So what you should do instead is configuring your AD name servers as the only nameservers for all of your clients and servers within the domian. Also, if you want to use Google's nameservers as forwarders, configure forwarders in your AD DNS servers' settings. Also, do read the documentation. Your case is explicitly covered in the official Technet documentation as well as in numerous howtos on Active Directory installations.

  • Thanks for elaborate answer. After configuring my router to only route to my local DNS server, and setting up forwarding on my DNS server to the Google DNS worked perfectly. – Deniz Zoeteman May 21 '13 at 9:48
  • Also, when you set up forwarding on the DNS server, does it automaticly add the Google DNS as secondary DNS server to Windows clients? I would assume not, but after setting up my router to only route to the local DNS server ipconfig -all still displays Google DNS as secondary DNS server even after a ipconfig -release & -renew and even a systeem reboot. Or are these settings cached somewhere? – Deniz Zoeteman May 21 '13 at 10:09
  • 1
    @TutorialPoint The forwarder configuration of the AD DNS servers does nothing to the clients' IP configuration. The DNS server information for the clients is distributed by your DHCP server. Change the scope's options accordingly so Google's DNS servers are not assigned to clients any longer. – the-wabbit May 21 '13 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.