I have installed an NFS server on an Ubuntu server system. The /etc/exports says

/      ,sync,fsid=0,no_subtree_check,root_squash)

The /etc/fstab on the client side says

wilson:/home/bronger /mnt/home_bronger nfs noauto,user   0  0

The mounting itself works without problems. /etc/mtab contains

wilson:/home/bronger /mnt/home_bronger nfs rw,noexec,nosuid,nodev,vers=4,addr=***,clientaddr=***,user=bronger 0 0

So far, so good. However, I cannot write to the mounted directory. I can, however, read files with permissions -rw-------. The only answer to this question says "It does seem that rpc.idmapd doesn't support ID to name mapping that would let you make changes to the file system". But it doesn't give reference, and I'm not yet prepared to believe that NFS4 is so badly designed that Kerberos is necessary for such a frequent use case.

I'm user #1000 on both machines.

  • 1
    So do you run rpc.idmapd? Did you have tied to run it with -f -v options and watch the debug output?
    – kofemann
    May 21, 2013 at 12:39


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.