40

I just installed a fresh new Windows 2012 x64 Virtual Machine.

The very first thing I did was install Google Chrome.

When I went to the Dashboard, I get the following error (or it's made to look like an error).

enter image description here

So,

  • Anyone know what this error is all about?
  • How can i 'fix' this?

Thank you kindly.

EDIT: Please don't suggest I uninstall G-Chrome as a fix.

6
  • 2
    If you don't want to remove Chrome, just set the Chrome Update Service to "Disabled" as neither it or Chrome proper is supported on Server 2012 yet.
    – jscott
    Commented May 23, 2013 at 2:14
  • 1
    So this would mean i would manually have to update chrome?
    – Pure.Krome
    Commented May 23, 2013 at 2:17
  • 5
    Why on Earth are you installing Chrome on a server? You shouldn't be web browsing on a server in the first place!
    – MDMarra
    Commented May 23, 2013 at 2:33
  • 3
    ^ Oh le sigh .......
    – Pure.Krome
    Commented May 23, 2013 at 3:46
  • 2
    I doubt he's doing his Amazon shopping on it... Commented Jun 2, 2017 at 8:14

5 Answers 5

61

Going through the Google forums, it seems like Google doesn't have any intention of "fixing" this behavior. Issue seems like that the service starts and then it stops quickly making Windows think it failed, though in reality it checks for updates (and may be other "stuff") and exits with no errors.

Since this is normal behavior, what I did was to remove the gupdate service from the Services drop down in the Services Detail View. This makes the Server Manager exclude it.

You'll find the checkbox in the Services Detail View, Services dropdown.

5
  • 3
    +1 Best Answer. Service will continue to run and keep Chrome updated while hidding it from the dashboard. No more red. Thanks. Commented Apr 14, 2016 at 13:00
  • 3
    +1 Drop down exists for Local server and All servers blocks in the dashboard. Both need to be updated.
    – Mat M
    Commented May 3, 2016 at 7:59
  • 1
    I notice that this naturally moves away from "All" services to "Multiple". Do you (or anyone) know if new services will still be monitored? i.e. I'd hate if turning off gupdate, this "stamps" the current list of monitored services. Commented Oct 2, 2016 at 1:57
  • Depends on what you mean by monitored. Services run as usual and if you have any 3rd party tools, they can query status via whatever the method. Disabling would simply make the service disappear from this dashboard only. (You can go to services.msc to check the state at any time.)
    – Madushan
    Commented Oct 2, 2016 at 22:54
  • I would like to know answer to @ChrisSimmons question too... i.e. if you install new services after doing this... are they selected or deselected in this cb list? I guess selected, but who knows...? Commented Apr 24 at 13:01
10

As @JScott suggested, I just changed the service from Automatic Delayed to Manual (or I could have also chosen Disabled).

And .. that fixed it.

enter image description here

1
  • 4
    better use Madushan answer: if Win 2012 monitoring is broken, counter-break it, rather than disabling Chrome auto-update.
    – Mat M
    Commented May 3, 2016 at 7:59
5

We had this issue too - tried manually starting and the service would stop automatically. Explanation of issues above was clear, so we removed the service from scope/view and are green.

Maybe I'm just a bit thick, but it took me a little while to find out how to filter the services, so I'll just add a few steps in hopes of clarify solution to others:

  1. Click the red Services link located in the Local Server group on the Server Manager Dashboard.
  2. Click the Services drop down on the Services Detail View. This will say "All" if you are not currently filtering services, it will say "Multiple" if you are already filtering
  3. Scroll down to "Google update Service (gupdate)" and un-check the box to filter it from this view.
  4. Click OK

You may have to repeat this in the "All Servers", also located on the Server Manager Dashboard.

Thank you again - this cleared our warning

0

Open the Windows Run utility. You can do this by using the keyboard shortcut Windows key + R or searching for Run using Cortana.

Once it opens, type services.msc and hit enter. (You can also open this window by opening Windows Control Panel > System and Security > Administrative Tools > Services.)

Scroll down to Google Update Service (gupdate) and Google Update Service (gupdatem). Double-click each item and in the General tab under Startup Type, select Disabled from the dropdown menu and click OK.

1
0

For Edge Chromium, the issue is the same.

However, for some weird reason, the two services, edgeupdate and edgeupdatem, have been named by Microsoft with a leading space making them to be sorted to the top:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .