3

I am using the Openlogic Centos image provided by Windows Azure. I have tried many times but when I run yum update it always said no packages marked for update, and the centos version is still 6.3. I have another machine set up much earlier and I am not sure why but if in fact update itself to 6.4. I guess it is problem with the in build repo? Does anyone know the right way to update to 6.4? Thanks a lot!

4

The people who built that virtual machine image disabled updating it by the simple expedient of running their own CentOS mirror, which they don't keep in sync with upstream, and then altering the yum configuration to only use their mirror.

You can replace their yum configuration files with ones from a standard CentOS system, which is what I did.

Keep in mind that if you do this, you will no longer get updates to the Hyper-V Integration Services package that is in their repository; you'll have to update that yourself manually. You also will need to update the Windows Azure Linux Agent yourself from Microsoft's github.

  • Thanks a lot! This is immensely helpful, as I helplessly trying all those disableexclude or removing packages and installing raw rpm. I would rather Azure just provide the native Centos image. May I ask is there a way to add the Hyper-V Integration Services updates in the repo? – user2122139 May 24 '13 at 18:34
  • You would have to make your own repo. – Michael Hampton May 25 '13 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.