Since about this monday we have had severe problems with our Citrix environment. The symptoms are users are experiencing very slow connections from time to time and from user to user, today we had problems with users are unable to print (although I haven´t had time to investigate it further). The sessions would freeze after a short time. This happens even if users ends up on another XenApp server. So it follows the user/users who are affected and not the XenApp-server they end up on.

Ok so here is the environment:

12 XenApp servers on IBM blades (not vmware). Windows 2003 32-bit servers. XenApp 4.5. 1 Web Interface (vmware) 1 data store/SQL server (vmware) 1 provisioning server which provisions the 12 XenApp servers above (we had 2 provisioningservers up to a couple a weeks ago when we saw that XenApp servers provisioned from 1 provisioning server died almost daily).

We publish applications to different "sites" and it began this monday with users in one site complaining about slow performance and one user had problems with the applications just crashes. There was a technician at the site who said it crashed immediately and a window stating "citrix has crashed" (or simila) appeared. It didn´t help to reinstall Citrix online plugin 11.2 as we use, even after clearing out the users profile files related to citrix. Others tried to use citrix on his computer but it didn´t work. His computer got reinstalled this wednesday and it worked good after that.

Now today all **** broke loose. 3 people in another site (we do NOT manage the sites, they are external customers so we dont have any control over their computers) complained about the citrix window just become blank and sometimes just black. I asked them to try some other application but it was the same error on all applications, not just the one they mainly use. Then after 4 hours the problems went away for a while. Then they come back again! And in the midst of all this they all were unable to print anything. I have worked with our citrix environment for 3 years and have never encountered a printingproblem so I guess it must be connected to this error as well. Only this "site" had printing issues, no one else.

A lot of information and vague info but if anyone has any tip I would appreciate it extremely much!

  • 1
    This sounds like a problem with the site you don't control, not your Citrix environment. – Tanner Faulkner May 24 '13 at 16:44
  • 1
    This sounds like a network problem. Check if the link is having any notable packet losses (packet loss rates > 2% would likely impair performance). Printing is especially susceptible to this as it needs to transfer a large stream of data over the virtual channel within the citrix connection. If losses are causing the TCP connection to back up repeatedly, the transfer will be stalling. – the-wabbit May 24 '13 at 18:12

It sounds like you are having a network issue of some kind. It's interesting that reimaging one of the workstations fixed it; it might be coincidence, or it might be the result of malware or a proxy being added somewhere in the chain (for instance, someone may have maliciously added a 3rd party proxy to a machine in order to try and hijack a session).

When the problems go away and come back, it's usually either load or network issues, and as it sounds like you are running this remotely for your clients, the latter is especially likely. Do a ping from one of the affected workstations to your citrix servers (send 100-200 packets) and see what the loss rate is. It should be no more than about 1 packet in 200, in my experience, if you are trying to do citrix over the link. It's also possible that you have an MTU issue, or even just bad cabling somewhere.

Since the problems are isolated to one site, it's highly likely that it is either a malware or network underprovisioning issue at that site.

  • As always with information from external customers it´s hard to actually know what is going on. But this monday site number 1 had problems and especially on one client where the citrixclient crashed and the computer had to be reinstalled. Then yesterday and the day before that site number 2 had issues with first slow performance and some printing issues at first and later connections that hung completely and no printers working. At the same time site number 3 had some complaints that the connections were unusually slow, although not unbarably slow, just unusually slow. – David Harrysson May 25 '13 at 9:23
  • One thing that is of interrest as well is that we have a lot of retries on the vDisks on the provisioning server. Several thousands retries on each vDisk. 10 000 retries on a couple of weeks of uptime. I have spoken with our network team and server team but they cant see anything wrong. It just seems as if this was the big problem then everyone would have the same issues, or? – David Harrysson May 25 '13 at 9:28
  • Not necessarily. However, if you suspect a hardware failure in your servers, look there first. – Falcon Momot May 25 '13 at 11:14
  • Any tips on how to troubleshoot the many retries issue on provisioning services? I have read the documentation but not found anything useful there. I entered verbose logging for one of my XenApp-servers in the provisioning console and the logs are suppose to end up here: C:\Documents and Settings\All Users\Application Data\Citrix\Provisioning Services\logs But I´m unable to find a log with any information about resending packages to my XenApp-host. If this underlying provisioning issue could be the root of my issues :/ – David Harrysson May 25 '13 at 11:38
  • Today we had major issues with sessions on the first site that we had a week ago. Not the one this friday. So it´s not isolated to one site, thats for sure now. I had to log people off their sessions that were unresponsive and eventually people could get their applications up and running again. They all had several sessions on several xenapp servers. – David Harrysson May 27 '13 at 15:44

To avoid guessing where the issue may lie, i would suggest proactive monitoring of your Citrix farm. If you are running Citrix XenApp 6.5, you may want to check Citrix EdgeSight. If you are on version 7 or higher, EdgeSight functionality is no longer supported. Look for third party tools. One i have used is the eG Innovations Citrix Monitor - see http://www.eginnovations.com/solutions/citrix-monitoring

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.