named.conf.local (included in named.conf)

zone "foo.com" {
    type master;
    file "/var/lib/bind/foo.com.hosts";

DNS zone

$ttl 600

foo.com.    IN  SOA server.hostname. mail.server.hostname. (
            600 )
foo.com.    IN  NS  server.hostname.

fake            A

dig test

dig fake.foo.com +trace
foo.com.             600     IN      SOA     server.hostname. mail.server.hostname. 1369844282 600 600 600 600

Why fake is not resolved? What i'm missing?

Some more details

DNS for this server are managed from a domain panel on a hosting.

On that DNS panel i've set a subdomain as NS record pointing to the server.

Hosting DNS Panel Records

@           A     
www     A     
ftp     A         
beta    A
_domainkey  NS

So, when i talk about the fake record, i mean that dig can't resolve fake._domainkey.foo.com because, as already said, answer me with the SOA and not with the record.


Have you tried reloading bind after making those files?

I'm not sure what your OS is, but one of these should do the trick:

$ rndc reload foo.com


killall -HUP named

These will reload the config without taking the service down. Barring that, the nuclear option:

service named restart


/etc/init.d/named restart

  • yes, thank you. I've already reloaded the zone. Now i've tried a bind9 restart (i'm on Ubuntu 12.04) but nothing, I keep to reach only the SOA – apelliciari May 29 '13 at 22:55
  • Have you verified that the zone is loading properly? Check the output of the commands named-checkzone foo.com /var/lib/bind/foo.com.hosts and named-checkconf -z, and check the name server's log file for errors on startup. – This isn't my real name May 30 '13 at 0:39
  • yes, everything seems regular gist.github.com/apelliciari/5676266 :( – apelliciari May 30 '13 at 7:39

the issues was in the _domainkey NS record in the hosting DNS panel, because it didn't work properly.

i've added the records directly in the DNS hosting panel and it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.