3

I'm trying to set up an automatic redirect from http://webmail.domain.com to https://webmail.domain.com/owa of our Exchange Server 2013 CU1 using the IIS interface.

The old trick to just redirect the Default Web Site or the iisstart.htm redirect only works with https://webmail.domain.com (note that we need to specifiy https). Using only http:// will end up in a 403 Forbidden page for IIS.

The question is: how to setup this correctly so our users can connect in webmail.domain.com and it automatically redirects to https://webmail.domain.com/owa

Thanks,

6 Answers 6

7

I was able to solve my own problem using IIS Rewrite Mod. I was little confused when found this, since Rewrite Mod is well know in Unix world with the Apache Web Server.

Anyway, just downloaded and installed the IIS Rewrite Mod from here: http://www.microsoft.com/en-us/download/details.aspx?id=7435

And then modify web.config in wwwroot with this XML code:

<configuration> <system.webServer> <rewrite> <rules> <rule name="HTTPS Redirect" stopProcessing="true"> <match url="(.*)" /> <conditions> <add input="{HTTPS}" pattern="off" ignoreCase="true" /> </conditions> <action type="Redirect" redirectType="Found" url="https://{HTTP_HOST}/{R:1}" /> </rule> </rules> </rewrite> </system.webServer> </configuration>

With this approach I was able to redirect HTTP to HTTPS in Exchange 2013.

And don't forget to disable the "Require SSL" option in the Default Web Site on IIS Control Panel or you'll get and 403 Unauthorised error page.

1
  • The rewrite mod is the best way to handle it. generating 403.4 errors is not a good idea. Commented Nov 13, 2014 at 18:49
4

I like to require SSL and bounce the 403.4 error to https://domain/owa on the root and OWA applications.

1
  • 2
    I think this is the best answer. No extra software to install, requires minimal configuration, and worked like a champ. Commented Nov 19, 2013 at 20:10
1

Good deal glad to see you found another way of doing this.

The way I have been doing this is by using the redirect to force a redirect to SSL by clicking the HTTP redirect on the default site. From there type in the absolute path like https://mail.domain.com/owa and then checking the "only redirect requests to content in this directory" checkbox. Turn off require SSL in the SSL settings and poof, you have your redirect with no rewrite mod required.

P.S. This article mentions an extra step to editing permission for downloading of the offline address book.

http://technet.microsoft.com/en-us/library/aa998359(v=exchg.150).aspx

1
  • This doesn't seem to work with Exchange 2013 and that's the problem the OP (and I) is having. Commented Nov 19, 2013 at 20:02
0

I know, for a fact, that simply redirecting default web page to https://mail.server.net/owa works perfectly fine with exch13. You must uncheck require ssl, but this is known. I have had this setup since inception and it works fine. You do NOT redirect the backend, only the default website.

-2

You can simply force redirection on default web site to - https://owa.domain.com/owa and remove "require SSL" in SSL Settings.

-2

Works perfectly. I would recommend this if you're using different URL's so you can keep using them instead of redirecting to one specific URL. We have about 10 different URLs for different companies (mail.company.com, mail.companyb.com, mail.companyc.com, etc.) and this works perfectly to preserve the URL.

1
  • Hi, and welcome to Server Fault! I down voted your answer because it appears that it is more of a comment in response to the OP or another answer, rather than an answer that could stand on its own. If you'd like to expand it a bit and explain what particular steps you would recommend, that would really help. Comments aren't enabled for you yet, but keep participating and soon you'll have access to them.
    – Kate
    Commented Apr 27, 2015 at 21:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .