2

When I tried to install CentOS 6.4 on a Citrix XenServer 6.0, after I hit install, the installation hangs at "Switching to clocksource hyperv_clocksource"

I have installed CentOS 6.0 without this issue on the same server.

Any suggestions is much appreciated, and thanks in advance

2

To get around this issue, you will need to set the clocksource to hpet. To do this, let grub load the screen, then hit the tab key. Add this to the end of the command: clocksource=hpet

I tried using clocksource=acpi_pm and clocksource=xen , however both fail. Only using hpet was I able to complete the install.

3
  • Also found that 'clocksource=jiffy' will work as well
    – Jake A
    May 30 '13 at 20:21
  • Awasome it's works, Thanks I am able to install it using clocksource=hpet
    – user179854
    Jul 1 '13 at 11:51
  • Dude thanks, I've been having this problem for days... Oct 8 '13 at 9:03
1

I have actually noticed this problem as well with xenserver 6.2

I ended up having to put clocksource=jiffies clocksource_failover=hpet

1
  • I was having the same problem as OP, and by setting clocksource=jiffies the installation could proceed. Many thanks for you reply! Aug 18 '16 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.