We switched from shared hosting to a VPS at HostGator. They told us we needed to go into the domain registrar (Moniker) and setup "private nameservers" as ns1.domain.com and ns2.domain.com. We did that, and set A records at Moniker to point to our server IPs. That worked for a while, and then randomly decided to stop working after about 4 days.

On the VPS, we have dns records for ns1.domain.com and ns2.domain.com which also point to our server IP addresses. I've been fighting this for days now and can't figure it out.

When I type in domain.com in my browser, it should go to the nearest (my ISP) DNS server and ask where to send it. If it doesn't know, it should go out and ask the next available one. I get that. But how does the DNS server update with the correct IP? Does it ask the registrar of a domain name? If ns1.domain.com points to our server, do we need it to be running DNS software? Can I instead make ns1.domain.com point to the ns1.moniker.com?

Can somebody please explain to me what a private name server is in this regard and how it works? The Google machine just isn't helping me understand this at a fundamental level.

  • Try running your domain through DNS Stuff or intodns.com type tools to see what errors are flagged. – jeffatrackaid Jun 6 '13 at 16:27

You may need to setup your nameservers at your registrar -- this is a different process than setting a domain to use a specific nameservers.

At your registrar, there should be an option to add "nameservers based on a hostname" or "custom nameservers" or something similar. The name varies from provider to provider.

You will know if you are on the right form because it will ask for both the IP and the nameserver domain name.

You will supply them with the nameserver name and IP.

These are called "glue records" and are required.

The reasons this is required is that if you try to lookup www.mydomain.com it will say check ns1.mydomain.com. But you can't check ns1.mydomain.com since you do not know the IP address. You cannot lookup the IP since ns1.mydomain.com says check ns1.mydomain.com. Glue records return the IP of your nameserver to prevent this lookup loop.

  • Turned out I had a configuration error in my /etc/named.conf file and BIND wouldn't start. Haha, I've been chasing shadows. Thanks for your help. – Jeremy Harris Jun 6 '13 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.