so I have a little problem. I have a piece of software that requires glibc (libstdc++.i686 is that needs glibc) (32 bit version) that is >= 2.10.90-7. The problem is, CentOS 5.9 only has glibc 2.5 or something like that... I have tried installing everything from RPM's etc, I just keep getting a BUNCH of dependencies errors...

  • 2
    If it is on the EPEL repo, use EPEL; if it isn't, compile it into RPMs from source using fpm. Don't pick random RPMs from nowhere. – Deer Hunter Jun 10 '13 at 2:06
  • Use CentOS 6, then. – Michael Hampton Jun 10 '13 at 2:35

The GLibC in EL should not be updated outside of what the distribution creator provides as it could cause issues with existing software; that software is not runnable on CentOS 5 without recompilation.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.