0

I'm trying to install IR Touch from IRTOUCHSYSTEMS. I download the drivers and install them but on dmsg I see:

usb 2-1.3: usbfs: process 8179 (irtouchServer) did not claim interface 0 before use

This message is repeated and touch does not work. I can not understand what is the meaning of this message. Can anyone help me to understand what is wrong and how to fix it.

# cat /etc/SuSE-release

openSUSE 11.4 (i586) VERSION = 11.4 CODENAME = Celadon

# uname -a

Linux grkiosk3 2.6.37.1-1.2-default #1 SMP 2011-02-21 10:34:10 +0100 i686 i686 i386 GNU/Linux

http://all.bg/~tdenev/irtouch_log_configs.zip

0

I contact the producer of the product to help me. First the producer send me other driver (not published on the site). With this driver message is missing from dmesg, but the touch still does not work. I sow that if I run irtouchServer manually I receive:

ret=-16 :Device or resource busy

This message is repeated.

I contact the producer again and it send me some convert tool that change the product number. Before convert the lsusb output was:

Bus 002 Device 005: ID 6615:0081 IRTOUCHSYSTEMS Co. Ltd.

After I run convert tool and re plug the touchscreen the output of lsusb is:

Bus 002 Device 005: ID 6615:0080 IRTOUCHSYSTEMS Co. Ltd.

  • I have exactly the same problem. Have you got a link to the flashing tool? I contacted the company some days ago but no answer yet :-( Thank you. Eric – user203645 Dec 26 '13 at 17:01
  • They send it to me by email. If you need it I will search for it and will upload it. (IF YOU USE IT IT'S ON YOUR RESPONSIBILITY, I AM NOT RESPONSIBLE FOR ANY DAMAGE ON THE DEVICE.) – botzko Dec 27 '13 at 7:29
  • Do you still have that file? I have the exact same problem... – jaapz Dec 29 '14 at 18:56
  • Yes, you will find it here: kontrax.bg/~tdenev/irtouch/linux_convertor.tar.gz - change ID on linux OS kontrax.bg/~tdenev/irtouch/windows_convertor.zip - change ID on windows OS If links does not work please write me. – botzko Dec 31 '14 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.