-4

well, I try to send email via google 'aspmx.l.google.com' server, port 25. I can send emial, technically. I just have to wait one minute to wait the sending process complete.

Then I try to do telnet to aspmx.l.google.com from my terminal and I found that it tries ipv6 first and then tries ipv4 after ipv6 is timeout.

I believe that is why I need to wait a minute for sending email.

BTW: I am doing it locally.

Does anyone know what is the real problem and how to fix it?

Thanks in advance

closed as not a real question by Ward - Reinstate Monica, Dave M, Rex, mdpc, Dennis Kaarsemaker Jun 11 '13 at 17:12

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

0

Sorry to answer your question with questions...

Which IPv6 address is it returning? Same as I get?

aspmx.l.google.com. 293 IN AAAA 2a00:1450:4013:c00::1a

Can you force ipv4 for your email server instead of trying to use ipv6 to verify that this is really your issue? Does your mail log's timestamps show a one minute delay even with ipv4 forced?

See here if you are using Postfix: http://linuxmoz.com/google-mail-ipv6-network-is-unreachable-postfix-ipv4-only-fix/

  • if I try: 'telnet aspmx.l.google.com 25', I wll get 'Trying 2607:f8b0:400d:c00::1b...', after 1 minute, it will try '173.194.76.26...', then it works – Jerry Meng Jun 11 '13 at 14:12
  • Are you using postfix? Can you force ipv4 in your email server and see if it doesn't delay 1 minute? – TheCleaner Jun 11 '13 at 14:15
  • I am not using postfix. By forcing use ipv4 is exact what I want. Actually, the point is that I am developing locally and running it somewhere at AWS instance. On the AWS instance, it is fine. So somehow I can just leave with it locally. However, we just want to know why, on my local machine, it will try ipv6 first than try ipv4. – Jerry Meng Jun 11 '13 at 14:19
  • If you have ipv6 enabled on your local computer since Google supports ipv6 it will try to resolve/connect using ipv6 first. You can disable ipv6 on your local machine to verify/test if you want. – TheCleaner Jun 11 '13 at 14:22
  • 1
    I seems know how to solve it, just uncomment precedence ::ffff:0:0/96 100 in my /etc/gai.conf file. – Jerry Meng Jun 11 '13 at 14:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.