I've compiled NGINX 1.4.1 with ssl support and wanted to secure my configuation with these lines:

ssl_prefer_server_ciphers on;
ssl_protocols        SSLv3 TLSv1 TLSv1.1 TLSv1.2;
ssl_ciphers          AES128-GCM-SHA256:AES256-GCM-SHA384:RC4-SHA:AES128-SHA256:AES256-SHA256;
ssl_session_cache       shared:TLSSL:16m;
ssl_session_timeout     10m;

This is the error I'm getting which I don't understand why it comes up:

nginx: [emerg] unknown directive "ssl_protocols        SSLv3"

my nginx configuration:

nginx version: nginx/1.4.1
built by gcc 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
TLS SNI support enabled
configure arguments: --with-http_dav_module --with-http_gzip_static_module --with-    http_stub_status_module --prefix=/opt/nginx --with-http_perl_module --with-http_ssl_module --with-perl=/usr/bin/perl --with-http_geoip_module --with-http_realip_module

maybe anyone knows what I'm doing wrong?

  • maybe its the SSLv3?
    – mdpc
    Jun 11 '13 at 21:25
  • 1
    Could you post more of your nginx config? Where are you calling the ssl_* settings?
    – chrskly
    Jun 12 '13 at 9:25

My understanding is that SSL is not enabled by default. Did you add the --with-http_ssl_module flag when building? It requires openssl.

  • 1
    yeah, nginx -V gives me "--with-http_ssl_module"
    – ghostrifle
    Jun 12 '13 at 6:23

For security reason SSLv3 is disabled by default even if you invoke SSL module.

Here is the tracking information and you can find also the fix if you really want to use SSLv3: https://trac.nginx.org/nginx/ticket/653

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.