I've been running Ubuntu 12.04 LTS for about 6 months on a computer that has 3 180gb SSDs in EXT4 RAID5 configured through the motherboard's BIOS. The OS froze and computer had to be forced down. On boot after the BIOS it just hangs at a blank screen. I booted off a live CD and was unable to mount /dev/dm-0, the RAID, because of a "superblock could not be read" error.

My RAID is made up of drives /dev/sda, /dev/sdb/, and /dev/sdc. Running "fdisk -l" showed a "missing partition table" error on /dev/sdb. I also ran testdisk and it returned unrecoverable partition errors. I wasn't able to run anything on that drive individually because it was considered in use. I booted with just that drive plugged in and tried messing with it, but got superblock errors.

I tried recovering the superblock from each of the backups listed to no effect. I zeroed the entire /dev/sdb drive and when I booted it went to rebuild mode for that drive, but I'm still hanging on boot of the OS and unable to mount the RAID or see any of the data.

I imagine I've only made things worse by zeroing one of the drives, so before I get to a state where my data becomes unrecoverable, what can I do to either fix this superblock error or recover my data?

  • 1
    Tempted to close (home setup, belongs to superuser). Anyhow - that is a good reason to go out and get a CHEAP and SMALL SSD (32gb or something) just as boot device. Bypasses all the issues a RAID may have. I avoid booting from a RAID that is not a mirror for pretty much that reason. – TomTom Jun 14 '13 at 7:56
  • That's a good idea. It's probably better to get two small drives and run them RAID 1 for boot? I don't want to get into issues like this again where I'm left unoperational for an extended period of time. – jchysk Jun 14 '13 at 17:08

You should clone your disks with dd and then try to recover data from the clones. Never ever try to fix original disks.

  • If I had dded the drives and were trying to recover the data or if I were a gambling man this doesn't help towards a solution. – jchysk Aug 3 '13 at 2:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.