Goals:

- Have two Dell switches trunked together with 1 cat5 cable.
- Have VLANs of the same number/name passing traffic from switch to switch.
- Not allowing any traffic from one VLAN to pass to a different VLAN.

Switches Used:

- Dell PowerConnect 2824 (24 port gigabit, level 2) [CORE SWITCH]
- Dell PowerConnect 2716 (16 port gigabit, level 2)

VLANs:

- VLAN1 (default by dell)
  Dell2824 Ports 1, Dell2716 Ports 1

- VLAN110 (workstations)
  Dell2824 Ports 7-16, Dell2716 Ports 2-14

- VLAN111 (printers)
  Dell2824 Ports 2-6

- VLAN112 (servers)
  Dell2824 Ports 18-22

Below is some snapshots of my current config and I want to know if I need to change anything to get it working right. As it stands it will not work as intended.

... After going through a bunch of work trying to prep images to show to you all I realized when trying to post them I need 10 rep to post images... :/ So sorry for a not so graphical representation of my settings below... I did create an album here though... vlan settings

  • Saw your comment...No problem here mate...feel free to redo the question...I'm deleting my answer now. – TheCleaner Jun 17 '13 at 21:42
  • I think I just figured it out! I needed to also set up the port settings as well. I had to alter the PVID on each port and set it to the VLAN ID it belongs to. For example on the 2824 Port 7 and the 2716 Port 2 I had to set the PVIDs to "110". Seems to be working perfect across the switches... Now on to getting the routing done on the ASA5505. ;) THANKS A BUNCH for helping me out TheCleaner! ... Can you answer your own question? If not TheCleaner, copy paste this into an answer and I'll green light it! ;) – Arvo Bowen Jun 17 '13 at 22:33
  • We encourage members to answer their own questions, so absolutely. Post the answer with as much detail as you can and then accept it as the answer. I'm surprised the PVID doesn't change on those ports when you add them as untagged access ports in their respective vlans though...leave it to Dell. :) – TheCleaner Jun 18 '13 at 13:14
  • Great! Thanks TheCleaner. I do loathe Dell's switches... Getting them to managed mode to start with is crazy... Then try to telnet to a level 2 switch like the 2716 and what... No telnet support??? :8 Yea plain and simple, you have to alter two different settings to get the VLANs to work correctly of trunked ports. – Arvo Bowen Jun 18 '13 at 17:53
up vote 2 down vote accepted

To set up VLANs using two Dell switches and a single trunk part you need to do the following using the Web GUI built into the switch... (For reference please use this link)

Note: For this example I will be using a Dell 2824 and a Dell 2716.

STEP 1 - (Setup the VLANs)

You first need to set up the VLANs themselves. In the web GUI for the first switch (2824) Browse to Home->Switch->VLAN->VLAN Members. Create a new VLAN by clicking the "Add" button (top right). Set your VLAN ID (Ex: "110") then set the VLAN Name (Ex: "workstations"). Leave "Authentication Not Required" set to "Disabled" which is the default. Click "Apply Changes". Go ahead and create a second VLAN the same way. Ex: ID "111", Name "printers".

STEP 2 - (Set what ports will be used in the VLANs)

On the (2824) browse to Home->Switch->VLAN->VLAN Members. Choose VLAN ID "110" the let it load real quick. Now you will see the ports associated with VLAN 110 below. The line that says "static" is where you want to be working at. Click on each port box (on the static line) and make the box say "U" for each port you want to be involved in the VLAN. In this example ports 7-17 are used. Next I changed the port 23 and 24 boxes to a "T" for tagged. These are use for my TRUNK ports only. After you set the settings appropriately click "Apply Changes". Be sure to set up the other vlan to (VLAN 111).

vlan 110 vlan 111

STEP 3 - (Setup the port settings to reflect each VLAN association)

So now we have to go into the port settings and set up each port to be associated with a certain VLAN. Browse to Home->Switch->VLAN->Port Settings. Click "Show All" (top right) to see a list of all the ports so you can change them at the same time. Set the PVID on each port to the VLAN ID it belongs to. For example mine would be all "1" (even on page 2) with the exception of ports "g2" through "g6" would be set to "111" and ports "g7" through "g17" which would be set to "110". In my images the PVIDs are all "1" but that was changed after the image was taken. Please make the changes on your system to reflect the example above in text.

port settings 1-12 port settings 13-24

STEP 4 - (Replicate settings to other switch)

In this example I just want to be able to carry the workstations vlan (VLAN ID 110) over to the Dell 2716 and use all ports on that switch I can for vlan 110. So on the Dell 2716 Web GUI open it up and browse to Home->VLAN Membership. Create a VLAN here with VLAN ID "110". In my example I usually leave PORT 1 on all switches alone and ALWAYS keep them on VLAN 1 for management purposes ONLY.

vlan 110

Don't forget the PORT settings for the 2716 switch!!! Ports "2" through "14" should be in VLAN "110". This switch makes it a pain.. You have to do them one at a time!!! :/

port settings

STEP 5 - (Test VLAN connectivity)

Try plugging one machine into port 7 on switch 2824 and another machine into port 2 on the 2716 switch. They should be able to ping each other (check machine firewall if not). Now try plugging the first machine into port 2 on the 2824 switch. Now they should NOT be able to ping each other.

When applying these VLAN settings, you must make sure to write the running config to the startup config in order for the settings to be maintained through a reboot.

On the powerconnect 28xx/27xx/35xx (units I have tested this on) do the following from the GUI:

System > File Management > Copy Files > Apply Changes

This will copy the running configuration to the startup configuration.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.