I have a Virtual Machine (in ESXi 5.1) running Ubuntu Server 12.04. When I try to boot my system I grub2 tells me "error: unknown filesystem". I've tried booting a Live CD then reinstalling grub from both a chrooted environment and by supplying the --root-directory option. I've even tried a boot-repair CD (results here) and reinstalling grub. Whatever I use to fix it, I'm getting the error "Path `/boot/grub' is not readable by GRUB on boot. Installation is impossible. Aborting."

To complicate things I'm running a RAID5 array (5 disks) using mdadm and btrfs for my filesystem. The btrfs tools that ship with Ubuntu 12.04 are really old. I've added ppa:cjwatson/grub (currently grub2 ver 2.00-2) and ppa:yofel/btrfs (currently btrfs-tools ver. 0.20~git20130524~650e656-0daily13) to my software sources to get more up to date utilities, with no help. The system was previously working before switching from a 4 disk RAID0 setup. I think this may have been the first reboot since the upgrade, but it was running fine for weeks using RAID5.

  • By adding a listing in device.map for the RAID array, I can get grub-install to run, but booting tells gives me an error of no such device.
    – jbo5112
    Jun 21, 2013 at 1:12

1 Answer 1


Grub can't actually boot from anything but a raid 1 or raid 0 mdadm device. You will need to add a /boot device somewhere and just set that up in raid 1/0/raw.

I would do something like this

the 2 new volumes below {a,b} can be file backed but should be on separate physical disks.

/dev/sd{a,b}1 mdadm raid 1 /boot (2 new disks (500MB or so)) 
/dev/sd{c..g}1 mdadm  raid 5 / (current disks)
  • Not correct. On a workstation, I'm successfully booting a RAID6 mdadm device. There is also a report of booting RAID-5 on the Gentoo forums forums.gentoo.org/viewtopic-t-888624-start-0.html
    – jbo5112
    Jun 18, 2013 at 11:23
  • The kernel's boot time assembly of RAID arrays only works for RAID 0 or 1, but isn't that deprecated for initramfs? I don't find any limit on grub2, but a lot of sources claim it works.
    – jbo5112
    Jun 18, 2013 at 12:21
  • Oh that is very cool. i may have to look into that.
    – Tacticus
    Jun 19, 2013 at 2:15
  • For now, I'm going with this, except using the raid1 support in btrfs (for data checks & easier maintenance). As easy as 2 new virtual disks are to create, I may just wait for them to finish RAID5 support in btrfs before looking at a proper fix without extra disks.
    – jbo5112
    Jun 21, 2013 at 1:21
  • replication with parity in btrfs is just going to be awesome when complete. my next FS upgrade will be to a btrfs based system as well. really good choice.
    – Tacticus
    Jun 23, 2013 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.